This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 180003 - matroxfb loaded causes X.org not to show in init 5 on G200
matroxfb loaded causes X.org not to show in init 5 on G200
Status: CLOSED DUPLICATE of bug 179041
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 09:38 EST by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-04 11:59:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2006-02-04 09:38:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.7.12-1.5.2

Description of problem:
I saw there is few other bugs about udev-071. I have following problem after update to udev.i386 071-0.FC4.2 with Matrox G200 card. It seems that with this udev version kernel loads  matroxfb on X startup. As far this could be nice, as long as I want to use matroxfb and it does not cause any other troubles. But in this case it does. When X is starting and also matroxfb is loaded the screen remains blank in init 5, leaving user without any clue what's wrong. Switching to Alt+F1 shows FB console, switching back to Alt+F7 shows X login. 

Using kenrel option "nofb" or "video=matroxfb:off" is useless as this module is most probably loaded by udev. I do not find any way how to disable fb loading. I may be wrong this is cause by udev, but it is deffinitely not due to kernel update - others only KDE and mozilla stuff were updated, so these I do not expect to cause it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Update to udev 071-0.FC4.2
2.Have matrox g200
3.start to init 5
  

Actual Results:  Blank screen.

Expected Results:  X login screen.

Additional info:

These are messages from kernel, they were not present before udev update:
Feb  4 15:29:12 localhost kernel: matroxfb: Matrox Millennium G200 (AGP) detected
Feb  4 15:29:12 localhost kernel: PInS memtype = 5
Feb  4 15:29:12 localhost kernel: matroxfb: MTRR's turned on
Feb  4 15:29:12 localhost kernel: matroxfb: 640x480x8bpp (virtual: 640x13107)
Feb  4 15:29:12 localhost kernel: matroxfb: framebuffer at 0xDD000000, mapped to 0xe1480000, size 8388608
Feb  4 15:29:12 localhost kernel: Console: switching to colour frame buffer device 80x30
Feb  4 15:29:12 localhost kernel: fb0: MATROX frame buffer device
Comment 1 David Eisenstein 2006-02-04 10:53:16 EST
Adam, this problem seems very similar to what Fred New reports in Bug #179041.
What happens if you try the workaround Fred tried in Bug 179014 comment 12?
Comment 2 Adam Pribyl 2006-02-04 11:52:46 EST
Are you sure you meant bug #179041? It is about "i810 video and generic LCD are
not dectected during install" reported by Seth Doty and there is no comment 12.
Comment 3 Adam Pribyl 2006-02-04 11:57:10 EST
Oh I see it is typo in second link. It is really #179041 and it seems similar
except it is different video card and I do not have any signs of X starting,
simply monitor clicks few time and leave black. If thats not matrox specific I
am aware this is common problem of simultaneous inicialization of FB and X.
Comment 4 Adam Pribyl 2006-02-04 11:59:30 EST

*** This bug has been marked as a duplicate of 179041 ***

Note You need to log in before you can comment on or make changes to this bug.