Bug 1800338 - need to backport changes for adding LB for IBMCloud
Summary: need to backport changes for adding LB for IBMCloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard: IBMROKS
: 1796140 (view as bug list)
Depends On: 1800337
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-06 21:41 UTC by ayma@us.ibm.com
Modified: 2020-03-10 23:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1800337
Environment:
Last Closed: 2020-03-10 23:53:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-ingress-operator pull 355 0 None closed Bug 1800338: [release-4.3] add LB changes for IBM Cloud Platform 2020-08-31 02:33:46 UTC
Github openshift cluster-ingress-operator pull 362 0 None closed Bug 1800338: [release-4.3] update to setDefaultPublishingStrategy() to add IBMCloudPlatform 2020-08-31 02:33:46 UTC
Red Hat Product Errata RHBA-2020:0676 0 None None None 2020-03-10 23:54:00 UTC

Description ayma@us.ibm.com 2020-02-06 21:41:25 UTC
+++ This bug was initially created as a clone of Bug #1800337 +++

Description of problem:
Need to use the IBM Cloud Platform to determine the correct annotations for the IBM Load Balancer deployments.  Without the annotations can't create public vs private load balancers

Version-Release number of selected component (if applicable):
4.4 and 4.3

Creating this bug so that I can create a 4.3 bug to backport the changes that went into 4.4

Comment 3 Dan Mace 2020-02-17 21:47:59 UTC
*** Bug 1796140 has been marked as a duplicate of this bug. ***

Comment 4 Hongan Li 2020-02-18 06:27:36 UTC
OCP QE has verified this with 4.3.0-0.nightly-2020-02-16-175702 and no regression. 

waiting for the feedback from IBM ROKS team.

Comment 6 Cesar Wong 2020-02-19 18:55:34 UTC
Failed to verify this in 4.3.0-0.nightly-2020-02-16-175702. The cluster ingress EndpointPublishingStrategy is not getting set to type 'LoadBalancerService' which then prevents the load balancer service type from being created.

Comment 7 Anping Li 2020-02-20 09:14:33 UTC
@cesar, Could you try this payload quay.io/openshift-release-dev/ocp-release:4.3.3-x86_64? The Advisory

Comment 8 Hongan Li 2020-02-20 09:41:50 UTC
The follow-up fix PR https://github.com/openshift/cluster-ingress-operator/pull/362 has not been merged, so maybe needn't to give a try with the 4.3.3 payload.

Comment 9 Anping Li 2020-02-20 09:50:51 UTC
@hongli, Thanks. I will ask Art to drop this bug from Advisory.

Comment 13 Cesar Wong 2020-02-27 04:01:17 UTC
Verified this is working with 4.3.0-0.nightly-2020-02-26-221811

Comment 14 Hongan Li 2020-02-28 07:40:39 UTC
Thank you Cesar.

Verified with 4.3.0-0.nightly-2020-02-26-221811 and no regression on other platforms. moving to verified.

Comment 16 errata-xmlrpc 2020-03-10 23:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.