Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1807665 - Environment Variables are not prepopulated in Edit flow
Summary: Environment Variables are not prepopulated in Edit flow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1808392 1808393
TreeView+ depends on / blocked
 
Reported: 2020-02-26 21:11 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1808392 1808393 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:21:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Environment Variables are prepopulated in Edit flow (1.26 MB, video/webm)
2020-03-04 10:01 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4517 0 None closed Bug 1807665: Edit Environment variables in edit flows 2020-06-23 08:51:06 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:22:11 UTC

Description Karthik Jeeyar 2020-02-26 21:11:38 UTC
Description of problem:

Edit flow doesn't pre populate the environment variables in advanced section

Version-Release number of selected component (if applicable):
4.4


Steps to reproduce:
1. Create an applicaiton with environment variables in advanced section
2. Go to edit flow from the topology
3. The applicaiton is intializing the new environment variable component instead of prepopulating with older values.

Actual results:

Environment variables under advanced section is not prepopulated


Expected results:
All the Environement variables must be prepopulated and should allow the user to update it

Additional info:

Comment 3 spathak@redhat.com 2020-03-04 10:01:50 UTC
Created attachment 1667439 [details]
Environment Variables are prepopulated in Edit flow

Comment 4 spathak@redhat.com 2020-03-04 10:02:41 UTC
Verified on build : 4.5.0-0.ci-2020-03-03-204641
Chrome browser: 76.0.3809.132

Comment 6 errata-xmlrpc 2020-07-13 17:21:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.