Bug 1808392 - Environment Variables are not prepopulated in Edit flow [openshift-4.4]
Summary: Environment Variables are not prepopulated in Edit flow [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
: 1808393 (view as bug list)
Depends On: 1807665
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 11:48 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Environment field is not set in the edit workload flow Consequence: Even if the workload has a environment variables it is not listed while the user edits the workload Fix: Add logic to prefill the environment variables when the user edits a workload Result: Now users can edit the workload's envrionment variables and also can add new environment variable.
Clone Of: 1807665
Environment:
Last Closed: 2020-05-04 11:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Reproducible video (2.64 MB, video/mp4)
2020-03-04 13:09 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4598 0 None closed [release-4.4] Bug 1808392: Edit Environment variables in edit flows 2020-04-20 09:15:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:33 UTC

Description Karthik Jeeyar 2020-02-28 11:48:50 UTC
+++ This bug was initially created as a clone of Bug #1807665 +++

Description of problem:

Edit flow doesn't pre populate the environment variables in advanced section

Version-Release number of selected component (if applicable):
4.4


Steps to reproduce:
1. Create an applicaiton with environment variables in advanced section
2. Go to edit flow from the topology
3. The applicaiton is intializing the new environment variable component instead of prepopulating with older values.

Actual results:

Environment variables under advanced section is not prepopulated


Expected results:
All the Environement variables must be prepopulated and should allow the user to update it

Additional info:

Comment 1 cvogt 2020-02-28 14:11:48 UTC
*** Bug 1808393 has been marked as a duplicate of this bug. ***

Comment 4 Gajanan More 2020-03-04 13:07:39 UTC
cvogt@redhat.com kjeeyar@redhat.com
I am able to reproduce this issue. Can you please have a look at the shared attachment? If it is expected then let me know, I will mark this as verified. 
I tried to validate this bug on:
Build:4.4.0-0.nightly-2020-03-04-000622 
Browser:Google Chrome Version 78.0.3904.108

Comment 5 Gajanan More 2020-03-04 13:09:32 UTC
Created attachment 1667486 [details]
Reproducible video

Comment 6 Karthik Jeeyar 2020-03-04 13:28:12 UTC
gamore@redhat.com The build 4.4.0-0.nightly-2020-03-04-000622 that you have used to validate the story is 13 hours ago and the PR got merged just two hours ago. Please verify the with the latest build that has the change. cc: cvogt@redhat.com

Comment 7 Gajanan More 2020-03-05 09:55:27 UTC
I have validated this bug on:
Build: 4.4.0-0.nightly-2020-03-05-014624
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 9 errata-xmlrpc 2020-05-04 11:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.