Bug 1807666 - need the ability to ability to create recovery scripts on disk for nodes
Summary: need the ability to ability to create recovery scripts on disk for nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: David Eads
QA Contact: ge liu
URL:
Whiteboard:
: 1807493 (view as bug list)
Depends On: 1806692
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 21:12 UTC by David Eads
Modified: 2020-05-04 11:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1806692
Environment:
Last Closed: 2020-05-04 11:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift library-go pull 721 0 None closed [release-4.4] bug 1807666: substitute all content for node name and revision 2020-06-25 05:51:37 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:19 UTC

Description David Eads 2020-02-26 21:12:02 UTC
+++ This bug was initially created as a clone of Bug #1806692 +++

This is only about making it possible to have the injection and substitution, not the content itself.

Comment 3 Suresh Kolichala 2020-03-10 17:48:56 UTC
*** Bug 1807493 has been marked as a duplicate of this bug. ***

Comment 4 ge liu 2020-03-24 08:18:49 UTC
Verified with 4.4.0-0.nightly-2020-03-23-115620

sh-4.4# cd /etc/kubernetes/static-pod-resources/etcd-certs/configmaps/etcd-scripts/
sh-4.4# ls
cluster-backup.sh  cluster-restore.sh  etcd-common-tools  etcd.env

the node name, ipaddress, certs is correct in etcd.env file.

Comment 6 errata-xmlrpc 2020-05-04 11:43:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.