Bug 18122 - Messages syslog'd to /var/log/messages
Summary: Messages syslog'd to /var/log/messages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
: 19889 30372 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 18:58 UTC by Peter Janes
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 22:03:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Janes 2000-10-02 18:58:44 UTC
The default syslog.conf for RedHat 7.0 logs crond messages to
/var/log/cron, as specified in
/etc/syslog.conf:

# Log cron stuff
cron.*                                                  /var/log/cron

and duplicates them in /var/log/messages, apparently by

# Log anything (except mail) of level info or higher.
# Don't log private authentication messages!
*.info;mail.none;authpriv.none                          /var/log/messages

Adding cron.none and restarting syslog successfully stops the logging to
messages.

6.2 seems to create its own /var/log/cron, without the syslog prefix:

root (09/24-04:22:00-11298) CMD (run-parts /etc/cron.weekly)

whereas 7.0 logs identical messages via syslog to both /var/log/cron and
/var/log/messages:

Oct  1 04:22:00 peterj CROND[19967]: (root) CMD (run-parts /etc/cron.weekly)

The vixie-cron package seems to be the same (3.0.1), just a different
build.  Have the build options changed to cause this duplication?

Comment 1 yacko 2000-10-10 02:43:17 UTC
Also observed this behavior and corrected it in the same way.

Comment 2 Bill Nottingham 2000-10-27 22:51:16 UTC
*** Bug 19889 has been marked as a duplicate of this bug. ***

Comment 3 kenneth_porter 2000-11-10 18:01:28 UTC
Additionally, logrotate fails because /etc/logrotate.d/syslog from
sysklogd-1.3.33-8 contains a cron entry that conflicts with the entry
in /etc/logrotate.d/cron provided by vixie-cron-3.0.1-39. Message is
"error: sylog:31 duplicate log entry for /var/log/cron". Fix is to
remove cron entry in /etc/logrotate.d/syslog.

Comment 4 Bill Nottingham 2000-11-13 20:27:40 UTC
Fixed in sysklogd-1.3.33-9.

(The last problem mentioned can be fixed by upgrading to the Red Hat Linux 7
vixie-cron package.)

Comment 5 Bill Nottingham 2001-03-02 21:06:12 UTC
*** Bug 30372 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.