Bug 181432 - vol_id fails to drop privileges
vol_id fails to drop privileges
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 182700 (view as bug list)
Depends On:
Blocks: 181306
  Show dependency treegraph
 
Reported: 2006-02-13 17:43 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 08:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use "nobody"'s primary group instead of assuming that it's named "nogroup" and going from there (2.67 KB, patch)
2006-02-13 17:43 EST, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2006-02-13 17:43:38 EST
Description of problem:
vol_id attemps to drop privileges to that of the 'nobody' user when it runs, by
switching to the 'nogroup' gid and the 'nobody' uid.  This fails on Fedora
because we don't have a 'nogroup' group.  (It also creates boot delays when
network-using nsswitch modules are in use, but that's a side-effect.)

Version-Release number of selected component (if applicable):
084-1.1

How reproducible:
Always

Steps to Reproduce:
1. Switch on "ldap" for use in "group" lookups in /etc/nsswitch.conf, preferably
with a default /etc/ldap.conf on the system.
2. Reboot.
  
Actual results:
Debug spew as vol_id tries to look up information about the group.

Expected results:
Quick bootup.

Additional info:
Why not just use the user's primary group ID?
Comment 1 Nalin Dahyabhai 2006-02-13 17:43:38 EST
Created attachment 124586 [details]
patch to use "nobody"'s primary group instead of assuming that it's named "nogroup" and going from there
Comment 2 Harald Hoyer 2006-02-14 02:19:36 EST
Very good suggestion! Thank you for the patch! :)
Comment 3 Gordon Messmer 2006-02-24 00:06:32 EST
*** Bug 182700 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Bierfert 2006-02-24 10:44:48 EST
ping

will this hit rawhide anytime soon or is there a test rpm somewhere?
Comment 5 Harald Hoyer 2006-02-24 10:55:51 EST
already should have with udev-084-4
Comment 6 Ignacio Vazquez-Abrams 2006-02-24 11:39:55 EST
So in other words you're saying that something completely different is causing
boot issues with udev and LDAP? How do we debug this?
Comment 7 Andreas Bierfert 2006-02-24 12:07:11 EST
Hm ok... the vol_id error went away here with current udev release but now there
are lots of other errors... Could this by any chance be
related/affected/affecting bug #181305?
Comment 8 Andreas Bierfert 2006-02-26 03:41:45 EST
With latest udev 084-6 everyting is working. This bug can be closed imho. Thanks.

Note You need to log in before you can comment on or make changes to this bug.