Bug 1815050 - Router e2e tests crash during upgrade from 4.1 due to un-migrated platform status field
Summary: Router e2e tests crash during upgrade from 4.1 due to un-migrated platform st...
Keywords:
Status: CLOSED DUPLICATE of bug 1830130
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.z
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1814357 1817460 1830130
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-19 11:38 UTC by Dan Mace
Modified: 2020-04-30 22:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1814357
Environment:
Last Closed: 2020-04-30 22:01:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24721 None closed Bug 1815050: Fix nil reference when accessing un-migrated platform status 2020-06-17 10:16:07 UTC

Description Dan Mace 2020-03-19 11:38:13 UTC
+++ This bug was initially created as a clone of Bug #1814357 +++

Description of problem:

The router metrics and header tests can crash when migrating from an old version (e.g. 4.1) that has an un-migrated platform status field.

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-upgrade-4.1-to-4.2-to-4.3-to-4.4-nightly/22

Longer term the field should probably be backfilled/migrated during an upgrade. For now, code needs to account for the possibility of a nil platform status and fall back to the old deprecated field.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from errata-xmlrpc on 2020-03-18 02:22:38 UTC ---

This bug has been added to advisory RHBA-2020:51809 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)

--- Additional comment from errata-xmlrpc on 2020-03-18 02:22:39 UTC ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2020:51809-01
https://errata.devel.redhat.com/advisory/51809

--- Additional comment from OpenShift Automated Release Tooling on 2020-03-19 00:40:30 UTC ---

Elliott changed bug status from ('MODIFIED',) to ON_QA.

Comment 1 Dan Mace 2020-03-25 19:10:24 UTC
Note the patch for this has been in-flight for 6 days, blocked on QE.

https://github.com/openshift/origin/pull/24721

Comment 4 Hongan Li 2020-04-03 04:13:00 UTC
Checked latest e2e test in https://testgrid.k8s.io/redhat-openshift-ocp-release-4.4-informing#release-openshift-origin-installer-e2e-aws-upgrade-4.1-to-4.2-to-4.3-to-4.4-nightly
didn't see the issue "invalid memory address or nil pointer dereference" any more.

Comment 5 Daneyon Hansen 2020-04-30 22:01:23 UTC

*** This bug has been marked as a duplicate of bug 1830130 ***


Note You need to log in before you can comment on or make changes to this bug.