Bug 18174 - pump will give up lease and leave system networkless
pump will give up lease and leave system networkless
Status: CLOSED DUPLICATE of bug 16069
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
: 21670 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-10-02 23:39 EDT by Seth Vidal
Modified: 2008-05-01 11:37 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-16 20:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
debug log of the pump setup (58.99 KB, text/plain)
2000-10-04 10:22 EDT, Seth Vidal
no flags Details

  None (edit)
Description Seth Vidal 2000-10-02 23:39:08 EDT
pump running on a fresh install of 7.0 - old_tulip (aka - real dec 21040

After about 3-6 hours pump will continue running but the ip will be given
up and all routes dropped - the card module is still loaded but nothing
else happens
running ifdown eth0 and ifup eth0 fixes it.

Tried running strace on pump -i eth0 but after it forks(I guess it forks)
it no longer gives debugging information - is there a better way of doing

DHCP server is the same one that works for MANY 6.2 machines and windows

The lease time on the dhcp server is 12 hours.
Comment 1 Seth Vidal 2000-10-03 09:24:28 EDT
as per suggestion from jeremy katz I turned on debug mode logging in syslog and
I'll have some hopefully useful information in a few hours.

Comment 2 Seth Vidal 2000-10-04 10:22:20 EDT
Created attachment 3739 [details]
debug log of the pump setup
Comment 3 Seth Vidal 2000-10-04 10:22:58 EDT
Pump believes it gets the lease but fails to setup the nic.

I've attached an annotated debug log file of pump.

you'll notice that it screws up at 23:46:52 and fails to renew the file -
you'll also notice the time goes a bit funky at one point - for reasons 
I'm not clear on - I'm going to get that locked down and re-run the test to    
see if maybe its something local and hardware related.

Comment 4 snikhi1 2000-10-13 11:43:19 EDT
I am not sure if my problem is related to this,. but seems to be so. I didn't have any problems with RH 6.1. After I upgraded to RH 7.0 I got the problem 
where my network connection is suddemly dropped. I have two network cards - one for external net and one for internal, and cable modem. Trying to fix 
the problem, I switched the cards but it didn't help. So, currently on external net I have 3COM 590, and on internal Intell EithernetPro 10. At first, I noticed 
the problem when I was downloading large file - during download network connection would disapear. Doing "network restart" would fix the problem. 
However, now I am noticing that network drop happens even when there is not much traffic at all, pretty much on random basis. Again, "network restart" 
fixes the problem. At the moment I am forced to restart network every 30 minutes from cron, so that I don't loose connection to my machine from outside. 
But this is very annoying. Any ideas?
Comment 5 Christopher Johnson 2000-10-18 11:44:45 EDT
I had the "pump will give up lease..." symptom with base 7.0.  ifconfig showed
normal except no inet addr: line and the box was completely unresponsive to the
address the dhcp server thought it had given a lease for.

After applying updates from updates.redhat.com including glibc-2.1.94-3 I have
not had the problem.

-- Chris
Comment 6 Markus Barckmann 2000-10-19 16:48:39 EDT
The problem also occours on a 3C90x. 
In my case pump looses the address excactly at the first renewal time. 
Executing pump fixes the problem immed.
Comment 7 Daniel Frank 2000-11-10 16:06:57 EST
After the network connection is droped linux cannot get an ip adress from my
router (running the dhcp-server) until i restart the router, but that might be
only a bad configuration of the router.

I have a 3c905b and after updating glibc the problem didn't disapear.  Ifconfig
doesn't show me the eth0-device anymore till my router is restartet and i ran
ifdown eth0; ifup eth0
Comment 8 jwitford 2000-11-25 22:04:01 EST
Have had similar problem on @Home network.
Worked ok on RH6, no renewal on RH7.
Everything else unchanged.
Updated libc without any improvement.
Have discovered that forced renewal (-R) not working because command-line hostname option
not being remembered. The @Home HDCP server does not respond with the requested hostname
My solution has been to modify source to add a reqHostname element to the pumpNetInfo struct
and use this in absense of hostname before reverting to system hostname() default.
But I have to wait 7 days before I will know if automatic renewal works ok (however -R is now ok).
Will post a patch then.

Comment 9 Duke Murden 2000-11-28 23:37:42 EST
I am having a similar problem with PUMP on version 6.2 and 7. I swapped network 
cards, tried dhcpcd. I finally upgraded to 7, bought two new network cards, 
replaced the 486 with a pentium 166 and the system ran for 14 days without a 
problem, then.., the error came back.

I believe this is not only a pump problem because it also occurs with dhcpcd, 
and when the inet addr line disappears the home network is down. I mean no 
computer can see each other until the inet line is back and the rest of the 
computers are static IPs.
Comment 10 David Ross 2001-01-08 13:09:40 EST
We're experiencing the same problem with RH7.0 and 2.2.18 kernel. We're going to
try 2.4.0.

This is really important to us!  We are trying to deploy a bunch of Linux boxes
that use DHCP and now they lock up within a day!  Anybody know how to fix this? 
Waiting desperately for a patch!!
Comment 11 Seth Vidal 2001-01-08 13:12:46 EST
I'd suggest giving dhcpcd a try and commenting out the pump call in /sbin/ifup

just grep for pump you'll find it easily enough
and make sure dhcpcd is installed - see if that fixes it.
I haven't tested it but I'm betting its something odd with pump and not the
driver for the nic.

good luck
Comment 12 Duke Murden 2001-01-08 13:46:18 EST
let me know if installing DHCP fixes it, it did not in 6.2 but it was more 
stable. I have a cront job that tries to renew the lease every 5 minutes and if 
it cannot it kills pump and restarts it. This works fine for a home firewall 
but it is not a production fix.
Comment 13 David Ross 2001-01-08 20:03:47 EST
My colleague has determined from the ifcfg scripts that simply removing the pump rpm will cause RedHat to use dhcpcd.  We're trying that and we'll let 
you know.
Comment 14 jwitford 2001-01-08 20:53:48 EST
I have a patch to remember the hostname during renewals.
This has fixed the problem for me.
Comment 15 David Ross 2001-01-17 00:18:41 EST
That did it!  Removing the pump rpm makes everything work wonderfully.
Which begs the question, why are we using it??  (I'm sure there's a reason - someone just has to enlighten me).
Comment 16 Duke Murden 2001-01-20 12:28:16 EST
Well it did not work for me. I have removed pump and am using dchpcd. It has 
been more stable, but when it goes down it hides the failure. Presently the 
only way I can determine that the network is down is to PING some site to see 
if the ping fails.

I still believe in my case it is some other problem that a start and start of 
either pump or dhcpcd corrects and not pump or dhcpcd. I also believe if I was 
not so cheap that I could fix my problem by getting a static IP from my ISP.
Comment 17 Jeremy Katz 2001-01-26 03:47:14 EST
*** Bug 21670 has been marked as a duplicate of this bug. ***
Comment 18 David Ross 2001-01-26 20:35:44 EST
You're right - removing pump does not help.  I was fooled.  ;-)
What is the patch?
Comment 19 Need Real Name 2001-01-27 15:45:02 EST
I've got the pump problem here as well. RH7+2.4.1-pre10+all updates (as of a
week ago) on a box with two
"3Com PCI 3c905 Boomerang"  cards.  Pump is running on eth0 attached to a GI
cable modem, some days I wake up and find the interface down, I can't reobtain
an address until I power cycle the cable CPE.  Eth1 is manually configured for
my lan.
Comment 20 John Major 2001-07-16 20:48:42 EDT
I have this problem on 3 RH7 systems. As an additional clue, this problem
also appears to ditch any IPX addresses for the interface as well. Also
the interface, as configured by pump, does not have the 'dynamic' flag set.
I am not sure of its intent. It does not appear in the man page, but does
show up in 'ifconfig --help'. I set it on one machine about 18 hours ago
and there is no sign of a problem since. I may have just had a quiet day,
but the longest it went before was around 8 hours. I'll just wait and see.
Comment 21 Elliot Lee 2001-07-20 00:37:30 EDT

*** This bug has been marked as a duplicate of 16069 ***

Note You need to log in before you can comment on or make changes to this bug.