Bug 1819849 - [4.4] CI: "ResourceQuota should create a ResourceQuota and capture the life of a secret" with "expected 6, actual 9"
Summary: [4.4] CI: "ResourceQuota should create a ResourceQuota and capture the life o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: devex
: 1761715 (view as bug list)
Depends On: 1785023
Blocks: 1819850
TreeView+ depends on / blocked
 
Reported: 2020-04-01 17:40 UTC by Adam Kaplan
Modified: 2020-05-04 11:48 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: client used to create pull secrets for the internal registry had a low rate limit Consequence: if a large number of namespaces are created in a short time window, it could take a long time for image registry pull secrets to be created Fix: increased the rate limit for the client used to create pull secrets for the internal registry Result: internal registry pull secrets are quickly created, even under heavy load
Clone Of: 1785023
: 1819850 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-controller-manager pull 89 None closed [release-4.4] Bug 1819849: Increase pull secrets controller QPS to 100 2020-05-04 20:41:13 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:48:12 UTC

Comment 1 Lukasz Szaszkiewicz 2020-04-08 07:27:06 UTC
*** Bug 1761715 has been marked as a duplicate of this bug. ***

Comment 4 W. Trevor King 2020-04-09 22:06:24 UTC
Moved back to ASSIGNED.  Not sure why the Bugzilla bot felt like it was time for MODIFIED.

Comment 6 W. Trevor King 2020-04-09 22:44:47 UTC
https://github.com/openshift/origin/pull/24816#issuecomment-610577083 failed a backport.  Not sure if it's been worked up manually yet.  If so, nobody linked back to origin#24816.

Comment 7 W. Trevor King 2020-04-09 22:48:30 UTC
I don't see anyone even attempting a backport of https://github.com/openshift/origin/pull/24754?

Comment 8 Ben Parees 2020-04-10 05:04:05 UTC
The critical PR for this bug has merged: 
https://github.com/openshift/openshift-controller-manager/pull/89

https://github.com/openshift/origin/pull/24754 does not appear to be needed because near as I can tell the test was never disabled in 4.4 (though i'm curious why not)

https://github.com/openshift/origin/pull/24776 should be backported once it merges, but it is not critical for this bug to be verified (it is adding an e2e test to this general area).

Comment 11 wewang 2020-04-15 02:08:44 UTC
Checked recent result of jobs, all passed, so verified it.

ResourceQuota should create a ResourceQuota and capture the life of a secret
jobs:
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.4-blocking#release-openshift-ocp-installer-e2e-aws-4.4
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.4-blocking#release-openshift-origin-installer-e2e-gcp-4.4

Comment 13 errata-xmlrpc 2020-05-04 11:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.