Bug 1819941 - OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users
Summary: OperatorHub doesn't show up after created a ClusterRoleBinding to `aggregate-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1819940
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-01 21:13 UTC by Samuel Padgett
Modified: 2020-04-14 16:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1819940
Environment:
Last Closed: 2020-04-14 16:18:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4902 None closed [release-4.3] Bug 1819941: Fix PackageManifest access review 2020-05-22 13:32:34 UTC
Red Hat Product Errata RHBA-2020:1393 None None None 2020-04-14 16:19:07 UTC

Description Samuel Padgett 2020-04-01 21:13:02 UTC
+++ This bug was initially created as a clone of Bug #1819940 +++

+++ This bug was initially created as a clone of Bug #1819938 +++

Description of problem:
OperatorHub view in console is depending on if the users have the permission to list package manifests and operator groups in all namespaces. 

However, after created a ClusterRoleBinding to `aggregate-olm-view` for non-cluster admin users, the OperatorHub still doesn't show up.

Version-Release number of selected component (if applicable):
OCP 4.4

How reproducible:
100%

Steps to Reproduce:
1. Create ClusterRoleBinding and bind to a non cluster admin user
2. Log in with that user


Actual results:
Didn't see OperatorHub view

Expected results:
OperatorHub view shows up.

Additional info:

Comment 3 XiaochuanWang 2020-04-10 05:49:39 UTC
Verified on 4.3.12
After grant the role "aggregate-olm-view" to a normal user, this user can visit Operator Hub from menu.

Comment 5 errata-xmlrpc 2020-04-14 16:18:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1393


Note You need to log in before you can comment on or make changes to this bug.