Bug 18201 - install bug
install bug
Status: CLOSED DUPLICATE of bug 17298
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 06:16 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 12:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-03 06:16:05 EDT
I tried to install Redhat 7.0 om my computer. Celeron 500 128 ram Riva TNT 
2 grafic card. 10/100Mcombo network card (local net) sb128. sony cd burner 
8x, Asus cdrom 40x (tried to install from both of them)

But all the time it hapends like this after i have gone through the 
install progress and just adfter all files has been decompressed this text 
appear. (se below) I tried all Redhat since 5.0 and all worked nice except 
the last two 6.2 and 7.0., But the 6.2 version vorked when i downloaded an 
updated version later.. I downloaded the 2 iso files from rh 7.0

Please mail me back !
--------------(2 error texts) after 2 different installations.,. all 
resulted in the same.. hanged after copying process..------


-----test1----
Traceback (innermost last):
File "/usr/bin/anaconda", line 438, in ?
intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1632, in 
doInstall
    self.writeConfiguration ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1384, in 
writeConfiguration
    self.createAccounts ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1168, in 
createAccounts
    stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/chfn can not be run

Local variables in innermost frame:
argv: ['/usr/bin/chfn', '-f', 'gustaf', 'gustaf']
root: /mnt/sysimage
stdin: 0
newPgrp: 0
stdout: 14
stderr: 2
command: /usr/bin/chfn
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>





-------------------test2----------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1632, in 
doInstall
    self.writeConfiguration ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1384, in 
writeConfiguration
    self.createAccounts ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1168, in 
createAccounts
    stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/chfn can not be run

Local variables in innermost frame:
argv: ['/usr/bin/chfn', '-f', 'Tobias Svensson', 'tobias']
root: /mnt/sysimage
stdin: 0
newPgrp: 0
stdout: 21
stderr: 2
command: /usr/bin/chfn
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Michael Fulbright 2000-10-03 14:53:02 EDT
Did you happen to unselect the util-linux package?  It is required for the
installer to work. We should probably add a test.
Comment 2 Michael Fulbright 2000-10-03 15:32:15 EDT
Related to bug 17928.
Comment 3 Michael Fulbright 2000-10-04 12:36:15 EDT
I think what has happened is there was a read error install the package required
for chfn and so the file was not installed.

Please try again with a different install image (yours is probably corrupt). Be
sure to use binary mode in ftp.

*** This bug has been marked as a duplicate of 17298 ***
Comment 4 Need Real Name 2000-10-06 09:06:59 EDT
I4ve tried to install everything and it resulted in the same.. no responce at 
all after cyl 1024.. and the strange thing is that it seemes not to work before 
cyl 1024 either if i use some other partition after cyl 1024..

In fact it worked once when i made a minimal install with (195MB) but some 
shared libraries were crasched during the start.. so there was something wrong 
with that to.,.

I downloaded the binary files from a ftp server and the checksum of that iso 
file was OK.. It might has been some wrong with the burning process.,. But i 
have installed it on another computer without QDI Brilliant X 1s/2000 
motherboard with a 4G HD (less than 1024 cylinders) and i worked nice.. but on 
another computer same hardware as me except a bigger HD it went the same way.. 
CRASH !..

Note You need to log in before you can comment on or make changes to this bug.