Bug 1820311 - Password expiry notifications to AD clients no longer work due to regression from fix for bug 1385665
Summary: Password expiry notifications to AD clients no longer work due to regression ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: krb5
Version: 8.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Robbie Harwood
QA Contact: Filip Dvorak
Josip Vilicic
URL: https://github.com/krb5/krb5/pull/1056
Whiteboard:
: 1805628 (view as bug list)
Depends On: 1733289 1805628
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-02 18:10 UTC by Robbie Harwood
Modified: 2020-11-04 21:13 UTC (History)
16 users (show)

Fixed In Version: krb5-1.18.2-2.el8
Doc Type: Bug Fix
Doc Text:
.Password expiration notifications sent to AD clients using SSSD Previously, Active Directory clients (non-IdM) using SSSD were not sent password expiration notices because of a recent change in the SSSD interface for acquiring Kerberos credentials. The Kerberos interface has been updated and expiration notices are now sent correctly.
Clone Of: 1733289
Environment:
Last Closed: 2020-11-04 01:59:24 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4541 0 None None None 2020-11-04 01:59:37 UTC

Description Robbie Harwood 2020-04-02 18:10:09 UTC
+++ This bug was initially created as a clone of Bug #1733289 +++

Description of problem:
Password expiry notifications to AD clients with SSSD no longer work due to regression from fix for bug 1385665.

Version-Release number of selected component (if applicable):
sssd-client-1.16.0-19.el7_5.8.x86_64


How reproducible:
Always

Steps to Reproduce:
1) Configure sssd to use auth_provider=krb5 or ad.
2) Configure short password expiry for user in AD. 

Actual results:
No expiry message is sent to any client e.g. gnome, ssh etc. 

Expected results:
Expiry message should be seen.

--- Additional comment from Sumit Bose on 2020-03-24 10:55:52 EDT ---

Hi,

I created https://github.com/krb5/krb5/pull/1056 and as suggested by Robbie in comment #6 I move this ticket to krb5. If the pull-request is not accepted please move the ticket back to SSSD so that we can think about alternative solutions.

bye,
Sumit

Comment 7 Sumit Bose 2020-06-09 05:30:14 UTC
*** Bug 1805628 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2020-11-04 01:59:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (krb5 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4541


Note You need to log in before you can comment on or make changes to this bug.