Bug 1820975 - [oVirt] disable tx checksum offload for workers
Summary: [oVirt] disable tx checksum offload for workers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Gal Zaidman
QA Contact: Michael Nguyen
URL:
Whiteboard: ovirt
Depends On: 1821005
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-05 07:45 UTC by Gal Zaidman
Modified: 2020-05-04 11:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1821005 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:48:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1628 0 None closed Bug 1820975: oVirt, fix disable tx checksum offload for workers 2020-05-13 22:24:37 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:48:58 UTC

Description Gal Zaidman 2020-04-05 07:45:02 UTC
Description of problem:
We need to disable tx checksum offload on worker nodes due to BZ#1794714.
This is currenly a workaround and is tracked for removal on BZ#1820581.

How reproducible:
Run network tests on a ovirt cluster, for example:
openshift-tests run openshift/conformance/parallel --dry-run | grep 'Network' | openshift-tests run -o /tmp/artifacts/e2e.log --junit-dir /tmp/artifacts/junit -f -

Actual results:
Some network tests will fail on the phase of NodePort

Expected results:
all tests pass

Additional info:
To check that the checksum is disabled ssh into the Worker VM and run:
1. nmcli conn show
take the conn ID
2. nmcli conn show {conn ID}|grep feature-tx-checksum
check that it is marked as off

Comment 1 Roy Golan 2020-04-08 09:45:15 UTC
raising priority because this is blocking the CI conformance test.

Comment 8 Michael Nguyen 2020-04-24 13:29:57 UTC
Verified based on CI results.

Comment 10 errata-xmlrpc 2020-05-04 11:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.