Bug 1821005 - [oVirt] disable tx checksum offload for workers
Summary: [oVirt] disable tx checksum offload for workers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Gal Zaidman
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1820975
TreeView+ depends on / blocked
 
Reported: 2020-04-05 11:54 UTC by Gal Zaidman
Modified: 2020-07-13 17:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1820975
: 1821798 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:25:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1606 0 None closed ovirt: disable tx checksum offload for workers 2020-06-23 09:50:10 UTC
Github openshift machine-config-operator pull 1621 0 None closed Bug 1821005: oVirt, fix disable tx checksum offload for workers 2020-06-23 09:50:10 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:25:56 UTC

Description Gal Zaidman 2020-04-05 11:54:48 UTC
+++ This bug was initially created as a clone of Bug #1820975 +++

Description of problem:
We need to disable tx checksum offload on worker nodes due to BZ#1794714.
This is currenly a workaround and is tracked for removal on BZ#1820581.

How reproducible:
Run network tests on a ovirt cluster, for example:
openshift-tests run openshift/conformance/parallel --dry-run | grep 'Network' | openshift-tests run -o /tmp/artifacts/e2e.log --junit-dir /tmp/artifacts/junit -f -

Actual results:
Some network tests will fail on the phase of NodePort

Expected results:
all tests pass

Additional info:
To check that the checksum is disabled ssh into the Worker VM and run:
1. nmcli conn show
take the conn ID
2. nmcli conn show {conn ID}|grep feature-tx-checksum
check that it is marked as off

Comment 3 Steve Milner 2020-04-07 20:49:43 UTC
Moving back to ON_QA to get it back to the right part of the process.

Comment 4 Roy Golan 2020-04-08 07:05:11 UTC
Steve this bug really failedqa and has a pull request to fix this.

https://github.com/openshift/machine-config-operator/pull/1621

Comment 5 Roy Golan 2020-04-08 09:46:30 UTC
Raising priority as this is blocking the ci conformance tests.

Comment 7 Michal Skrivanek 2020-04-08 12:42:34 UTC
This change is not really relevant on 4.5 and is just a workaround for network connectivity with openshift-sdn. 
CI validation is good enough

Comment 8 errata-xmlrpc 2020-07-13 17:25:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.