Bug 1821849 - Broken links to "OpenShift Cluster Manager" in ARO v4
Summary: Broken links to "OpenShift Cluster Manager" in ARO v4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1821846
Blocks: 1821852
TreeView+ depends on / blocked
 
Reported: 2020-04-07 17:45 UTC by nelde
Modified: 2020-05-04 11:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1821846
Environment:
Last Closed: 2020-05-04 11:48:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4956 None open [release-4.4] Bug 1821849: Hide `OpenShift Cluster Manager` when branding is `azure` 2020-04-14 08:58:25 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:00 UTC

Description nelde 2020-04-07 17:45:13 UTC
+++ This bug was initially created as a clone of Bug #1821846 +++

Description of problem:
"OpenShift Cluster Manager" links don't work in ARO v4

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Create ARO v4 cluster
2. Navigate to console
3. Click "OpenShift Cluster Manager" link

Actual results:
Can't navigate to URL

Expected results:
Link shouldn't be present if branding is "azure"

Additional info:

Comment 3 shahan 2020-04-15 02:44:50 UTC
~~~
oc edit consoles.operator.openshift.io/cluster
console.operator.openshift.io/cluster edited
~~~

consoles.operator.openshift.io/cluster spec configuration:
~~~
spec:
  customization:
    brand: azure
  managementState: Managed
~~~
The OLM link under clusterID was hidden on overview page.
4.5.0-0.nightly-2020-04-14-194131

Comment 4 shahan 2020-04-15 02:56:19 UTC
sorry, the verify payload should be 4.4.0-0.nightly-2020-04-14-222426

Comment 6 errata-xmlrpc 2020-05-04 11:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.