Bug 1821852 - Broken links to "OpenShift Cluster Manager" in ARO v4
Summary: Broken links to "OpenShift Cluster Manager" in ARO v4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.z
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1821850 (view as bug list)
Depends On: 1821849
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-07 17:51 UTC by nelde
Modified: 2020-04-30 01:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1821846
Environment:
Last Closed: 2020-04-30 01:28:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4957 None closed [release-4.3] Bug 1821852: Hide `OpenShift Cluster Manager` when branding is `azure` 2020-04-27 20:20:06 UTC
Red Hat Product Errata RHBA-2020:1529 None None None 2020-04-30 01:28:22 UTC

Description nelde 2020-04-07 17:51:45 UTC
+++ This bug was initially created as a clone of Bug #1821846 +++

Description of problem:
"OpenShift Cluster Manager" links don't work in ARO v4

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Create ARO v4 cluster
2. Navigate to console
3. Click "OpenShift Cluster Manager" link

Actual results:
Can't navigate to URL

Expected results:
Link shouldn't be present if branding is "azure"

Additional info:

Comment 1 Samuel Padgett 2020-04-07 18:01:22 UTC
*** Bug 1821850 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2020-04-17 06:20:40 UTC
1. Check if fixes are merged in 4.3.0-0.nightly-2020-04-17-001437

# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-04-17-001437 --pullspecs | grep console
  console  quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c68adb261b45db3881ceebd14cc8617ac0ffcf6249a7f22ceab4da91e3416369
  console-operator  quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:7075883e224ceb49d377e4082a8921fe193beac9feae32e3e1e9e8ecd30f9a9f

# oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c68adb261b45db3881ceebd14cc8617ac0ffcf6249a7f22ceab4da91e3416369 | grep commit
             io.openshift.build.commit.id=3752f02fbb73aabb8c711bec4d5dfa2c80657bda
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/3752f02fbb73aabb8c711bec4d5dfa2c80657bda

# git log 3752f02fbb73aabb8c711bec4d5dfa2c80657bda | grep '#4957'    //nothing returned 


Will check on newer 4.3.z build

Comment 6 Mike Gahagan 2020-04-17 18:03:33 UTC
HEAD is now at 9fbe0f8fb Merge pull request #4957 from openshift-cherrypick-robot/cherry-pick-4837-to-release-4.3
[m@localhost console]$ git log
commit 9fbe0f8fb207f9510c4915f8cc884e96c6a6f94a (HEAD, origin/release-4.3)
Merge: 3752f02fb 909248895
Author: OpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>
Date:   Thu Apr 16 18:30:42 2020 -0700

    Merge pull request #4957 from openshift-cherrypick-robot/cherry-pick-4837-to-release-4.3
    
    [release-4.3] Bug 1821852: Hide `OpenShift Cluster Manager` when branding is `azure`

[m@localhost console]$ oc adm release info registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-04-17-135300 --pullspecs | grep console
  console                                       quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6dde72df705c7dc4d3ba8ca3568d2d034f2d08d354c3df53d100e3a680b14429
  console-operator                              quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b07710f5c5b0c3cc56311b63416e4037c8d014502e58af2634e178d41e934311

[m@localhost console]$ oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6dde72df705c7dc4d3ba8ca3568d2d034f2d08d354c3df53d100e3a680b14429 | grep commit
             io.openshift.build.commit.id=9fbe0f8fb207f9510c4915f8cc884e96c6a6f94a
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/9fbe0f8fb207f9510c4915f8cc884e96c6a6f94a

will verify with the 2020-04-17-135300 build.

Comment 7 Mike Gahagan 2020-04-17 19:09:54 UTC
 Verified using 4.3.0-0.nightly-2020-04-17-135300 with the reproducer mentioned in:
https://bugzilla.redhat.com/show_bug.cgi?id=1821846#c5

Comment 9 errata-xmlrpc 2020-04-30 01:28:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1529


Note You need to log in before you can comment on or make changes to this bug.