Bug 18242 - Installation error
Installation error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
: 18241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-03 12:53 EDT by Mattie Bien
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-10 15:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump (990 bytes, text/plain)
2000-10-03 12:55 EDT, Mattie Bien
no flags Details

  None (edit)
Description Mattie Bien 2000-10-03 12:53:59 EDT
after saying "reading package information", I get:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: MAKEDEV
Local variables in innermost frame:
self: <comps.HeaderList instance at 824ebc8>
item: MAKEDEV
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10
<failed>
Comment 1 Mattie Bien 2000-10-03 12:55:09 EDT
Created attachment 3689 [details]
Anaconda Dump
Comment 2 Mattie Bien 2000-10-03 12:57:17 EDT
*** Bug 18241 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2000-10-03 14:41:18 EDT
Please verify that the MAKEDEV package is present in the correct location and
has the correct md5sum.

Most likely you got a corrupted version of the file.
Comment 4 Michael Fulbright 2000-10-03 15:00:10 EDT
Please run the 'md5sum' command on the MAKEDEV rpm you have and I can see if it
is corrupt or not.
Comment 5 Michael Fulbright 2000-10-06 17:36:53 EDT
This is almost certainly due to a corrupted download of the 7.0 release.

Try downloading again with the 'binary' ftp option if applicable.

*** This bug has been marked as a duplicate of 18019 ***
Comment 6 Mattie Bien 2000-10-07 04:19:41 EDT
The problem is : There is no makedev package (or I don't know the name, that's 
also possible).
Now I installed RedHat 6.2 and tried to upgrade it to RH7, but that didn't work 
either. What should I do?
Comment 7 Mattie Bien 2000-10-09 11:11:43 EDT
I downloaded all the files of ftp.redhat.com in binary mode, and it still 
doesn't work ! What's wrong?
Comment 8 JasonC 2000-10-11 00:32:12 EDT
I get the same problem. I'm setup as follows:

- PII/300, 128MB, ATI FURY 128, 3Com509B, 10.2GBHDD. 

Any help would be appreciated.

J.

--------------------------------------------------------

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/SAMHAIN/c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 9 Michael Fulbright 2000-10-26 18:21:47 EDT
The final comment here is a problem which is fixed by a recent anaconda errata
at
http://www.redhat.com/errata. It is a dupe of bug 18032.


Comment 10 Mattie Bien 2000-10-30 08:14:19 EST
It is not a dupe, it just doesn't ask for an update disk.
When I boot with my installation disk, @ the boot prompt, I type: linux update
Then the installation starts, but Anaconda still crashes before asking me an 
update-disk. I'm setup as follows :
Pentium III 500, NVIDIA Riva TNT2 model 64, hda : 12.1 GB, hdb : 1.51 GB.
What should I do now? Please help me.
Comment 11 Mattie Bien 2000-11-02 15:14:59 EST
Sorry, forgot to add these : 
Creative Sound Blaster AudioPCI 128, Generic 33600 bps modem (not in use), 
Logitech WheelMouse I , 3Com Etherlink XL TPO 10 Mb Ethernet NIC (3c900B-TPO), 
3Com Fast Etherlink XL 10/100 Mb TX Ethernet NIC (3c905B-TX), Intel 82371AB/EB 
universal host-controller for PCI to USB, one USB root hub, Intel 82371AB/EB 
PCI BusMaster IDE-Controller. That's almost everything I know.
Can you help me out of this. That bugfix on the errata page doesn't help me a 
thing. I just did what they said, but it crashes before asking me any disk.
(Crashes after I made all the choices about Network, TimeZone, etc. He says 
something like "loading Anaconda files" (or something like it), and then I get 
the same message (see ANACDUMP.TXT)). I already re-downloaded all the files, 
but it still doesn't work. By the way, is there already a driver supporting the 
High Point Technology UDMA Controller, cause I'm fucking up my moms computer, 
mine is still intact...
Comment 12 Michael Fulbright 2000-11-10 12:38:04 EST
The original problem is most certainly due to a corrupt hard drive install
image. Make sure you have downloaded all the required files in a binary safe way.

The other problem reported by jasoncharette@hotmail.com is fixed by the errata
for the 7.0 anaconda. Be sure you boot with 'linux updates'.
Comment 13 Mattie Bien 2000-11-10 13:56:16 EST
That's impossible! I downloaded the whole RedHat 7 CD 5 times, each time from a 
different FTP-site (including ftp.redhat.com), each time in binary mode, and 
each time I got the same freakin' error ! What's wrong with my system ? Help me 
out of this, will ya? Thanx.
Comment 14 Michael Fulbright 2000-11-10 15:41:37 EST
Hard drive installs work for us in our testing. I would recommend you try an FTP
or HTTP install, or perhaps downloading the ISO images and burning your own CDs.
There are also a variety of sources of CDs you can order, from Red Hat or others.

This is not an anaconda defect to the best that I can determine.
Comment 15 Alex Falkenberg 2001-01-14 18:29:41 EST
I go through package selection and all that fine; I get the "Loopback: creating
loopback filesystem on /dev/hdb5..." window; it does its thing and eventually
goes away, replaced by a "Formatting: formatting / filesystem" window, which
lasts about 5-10 seconds or so, give or take...before I get a popup with the
contents attached below.  I can go no farther, and the install fails and I'm
done.

Now, before you go and hit  Ctrl-V and  paste what seems to have become the standard, no-fault reply, read on.

 I've read almost everything there is  to read about this; I've tried the update img.  No dice.

You've mentioned corrupt HD install files over and  over again.  Well,  I'm doing an FTP install, and have tried a variety of mirrors. Still no dice.  I've remade all the  boot disks, drivers disk, and  updates disk several times. Carefully, methodically.
 
Still no dice.   And I'm apparently not the only one who still can't overcome the problem, despite no small amount of trying.

My suggestion is that there really IS something more going on here than bad/corrupt FTP'ing.  The update isn't working for everyone. Something ELSE is happening.

Now, what is it?

Please,  toss this around with your folks a bit more.

Thanks for your time.

-agf

============

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in
doInstall
  File "fstab.py", line 666, in makeFilesystems
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

===========

Note You need to log in before you can comment on or make changes to this bug.