Bug 1828744 - SLIRP must not be an option for connecting interfaces
Summary: SLIRP must not be an option for connecting interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks: 1828849 1831606
TreeView+ depends on / blocked
 
Reported: 2020-04-28 09:46 UTC by Fabian Deutsch
Modified: 2020-07-13 17:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: SLIRP can be chosen in the UI, but the feature is not supported in the product. Consequence: Users can use something which was never there, and the VM will fail to boot. Workaround (if any): not to use it Result:
Clone Of:
: 1828849 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:32:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5244 None closed Bug 1828744: do not support SLIRP NetworkInterface in NIC modal 2020-09-07 14:33:54 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:32:39 UTC

Description Fabian Deutsch 2020-04-28 09:46:49 UTC
Description of problem:
Today the OCP 4.4 UI with CNV offers to create VM vNICS with a SLIRP binding, this must not be permited in downstream, as in downstream we do not have slirp support (it's technically not there).

Version-Release number of selected component (if applicable):
CNV 2.3

How reproducible:
Always

Steps to Reproduce:
1. Create a VM
2. Select to add an additional vNIC, see SLRIP option in the list of bindings
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fabian Deutsch 2020-04-28 09:47:53 UTC
Moving to high, as a VM cerated with that binding will not boot iiuic

Comment 2 Nelly Credi 2020-04-28 13:04:33 UTC
This is bad
Moving to OCP under console kubevirt plugin

Comment 4 Nelly Credi 2020-04-28 13:09:45 UTC
@Andrew I think we will need to document this issue - to recommend users not to use SLIRP

Comment 5 Tomas Jelinek 2020-04-28 13:27:52 UTC
ok, cloning for 4.4.z

Comment 6 Andrew Burden 2020-04-28 14:59:38 UTC
@Nelly
Release note PR is ready for review:
https://github.com/openshift/openshift-docs/pull/21615

Comment 9 Guohua Ouyang 2020-05-14 02:40:01 UTC
verified on 4.5.0-0.nightly-2020-05-12-065413.

Comment 10 errata-xmlrpc 2020-07-13 17:32:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.