Bug 1829276 - Rerunning a cancelled pipeline run shows cancelled pipeline only
Summary: Rerunning a cancelled pipeline run shows cancelled pipeline only
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: All
high
high
Target Milestone: ---
: 4.3.z
Assignee: Abhinandan Das
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1828784
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 10:34 UTC by Abhinandan Das
Modified: 2020-06-17 20:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1828777
Environment:
Last Closed: 2020-06-17 20:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
pipeline1 (103.03 KB, image/png)
2020-06-02 05:50 UTC, Gajanan More
no flags Details
pipeline2 (97.77 KB, image/png)
2020-06-02 05:51 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5228 None closed Bug 1829276: fix(prun): Rerun cancelled runs | release-4.3 2020-06-01 07:56:24 UTC
Red Hat Product Errata RHBA-2020:2436 None None None 2020-06-17 20:28:16 UTC

Description Abhinandan Das 2020-04-29 10:34:48 UTC
+++ This bug was initially created as a clone of Bug #1828777 +++

Description of problem:

Rerunning a cancelled pipeline run shows cancelled pipeline only

Version-Release number of selected component (if applicable):
4.3

How reproducible:
Try to rerun a cancelled pipelinerun

Steps to Reproduce:
1.Goto pipelinerun list
2.Rerun a cancelled pipelinerun

Actual results:
A new cancelled run is created

Expected results:
A new starting/running run must be created

Comment 3 Gajanan More 2020-06-02 05:50:17 UTC
Created attachment 1694249 [details]
pipeline1

Comment 4 Gajanan More 2020-06-02 05:51:23 UTC
Created attachment 1694250 [details]
pipeline2

Comment 5 Gajanan More 2020-06-02 05:52:07 UTC
I have validated the bugzilla on:
4.3 Build: 4.3.0-0.ci-2020-06-02-004500
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshots 
Marking this as verified.

Comment 9 errata-xmlrpc 2020-06-17 20:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2436


Note You need to log in before you can comment on or make changes to this bug.