Bug 183018 - error: rpmtsOrder failed, 289 elements remain
Summary: error: rpmtsOrder failed, 289 elements remain
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 183088 183247 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-25 12:04 UTC by Axel Thimm
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 19:50:50 UTC
Type: ---


Attachments (Terms of Use)
/root/install.log after bad install (69.72 KB, text/plain)
2006-02-27 19:51 UTC, Thomas J. Baker
no flags Details

Description Axel Thimm 2006-02-25 12:04:56 UTC
Description of problem:
Upon installation via pxe/vnc the following output is seen on the console:

Press <enter> for a shell
Starting graphical installation ...
XKB extension not present on :1
error: rpmtsOrder failed, 289 elements remain

Version-Release number of selected component (if applicable):
today's rawhide

Comment 1 G.Wolfe Woodbury 2006-02-26 02:56:11 UTC
also seen on i686 arch install, 

Comment 2 Jeremy Katz 2006-02-27 16:59:57 UTC
We're actively looking into this now...

Comment 3 Jeremy Katz 2006-02-27 17:49:11 UTC
*** Bug 183088 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2006-02-27 19:36:22 UTC
*** Bug 183247 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2006-02-27 19:50:50 UTC
Fixed by breaking a dependency cycle that was causing lots of packages to not
get sorted in the rpm transaction properly.

Comment 6 Thomas J. Baker 2006-02-27 19:51:24 UTC
Created attachment 125340 [details]
/root/install.log after bad install

I never saw any mention of rpmtsOrder but here is the install.log with the
scriplet errors. I can include the anaconda.ks and install.log.syslog if need
be.

Comment 7 Chris Lumens 2006-02-27 20:01:07 UTC
Thomas - this appears to be the same issue.  Note that in the install.log, lots
of scripts are failing.  This is because packages are getting installed before
other packages that contains the things they are running in %post scripts.  In
particular, look at all the "command not found" messages in relation to where
coreutils gets installed.


Note You need to log in before you can comment on or make changes to this bug.