Bug 1832232 - Gather image registry config
Summary: Gather image registry config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Michal Fojtik
QA Contact: Angelina Nikiforova
Radek Vokál
URL:
Whiteboard:
Depends On:
Blocks: 1834629 1834677 1836816
TreeView+ depends on / blocked
 
Reported: 2020-05-06 11:16 UTC by Michal Fojtik
Modified: 2020-09-22 10:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1834629 1834677 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:35:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift insights-operator pull 100 None closed Bug 1832232: Gather image registry config 2020-09-22 10:35:04 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:35:43 UTC

Description Michal Fojtik 2020-05-06 11:16:51 UTC
Description of problem:

Insights operator should gather image registry config (oc get config.imageregistry.operator.openshift.io/cluster -oyaml)

This is needed to drive deprecation of certain fields in this config, but also it is generally useful to know and understand how customers configure the registry.

Version-Release number of selected component (if applicable):


How reproducible:

After this change merge, the "config/imageregistry" inside payload the insights operator send, should have the image registry config.

Comment 3 Angelina Nikiforova 2020-06-25 11:42:45 UTC
Fixed and verified in 4.5.0-0.nightly-2020-06-25-033011.

IO archives contain config/imageregistry.json which corresponds to "oc get config.imageregistry.operator.openshift.io/cluster -oyaml"

Comment 4 errata-xmlrpc 2020-07-13 17:35:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.