Bug 183302 - qt 3.3.5+ breaks IM preedit in kbabel
qt 3.3.5+ breaks IM preedit in kbabel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n, Regression, Reopened
: 196114 (view as bug list)
Depends On:
Blocks: 171491 FC6Blocker SCIM FC5Update 196114
  Show dependency treegraph
 
Reported: 2006-02-27 21:18 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.3.6-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-02 04:58:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample po file (319.78 KB, text/plain)
2006-02-27 21:18 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2006-02-27 21:18:52 EST
Description of problem:
Noticed that even with XIM bridge, it is not possible to use SCIM with kbabel.

Version-Release number of selected component (if applicable):
scim-qtimm-0.9.4-2.1.1
scim-1.4.4-6
kdesdk-3.5.1-1.2

How reproducible:
Always

Steps to Reproduce:
1.start kbabel in any CJK locale
2.open the po file attached and start to input with SCIM
3.
  
Actual results:
application unable to accept any input

Expected results:
should be able to input

Additional info:
Comment 1 Lawrence Lim 2006-02-27 21:18:53 EST
Created attachment 125372 [details]
sample po file
Comment 3 Lawrence Lim 2006-03-03 01:34:39 EST
Good news, tried with scim-1.4.4-8 and kdesdk-3.5.1-1.2 in today's rawhide.
Things looks ok with XIM bridge. As a result of XIM, switching IME is not
possible. The aux allow users to switch IME, though it seems like it has been
changed, nothing can be input.

Noticed the following error message in the g-t.

Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so:
  Plugin uses incompatible Qt library!
  expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux g++-4.*
full-config".
Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqimsw-none.so:
  Plugin uses incompatible Qt library!
  expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux g++-4.*
full-config".
Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqsimple.so:
  Plugin uses incompatible Qt library!
  expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux g++-4.*
full-config".
Conflict in /usr/lib/qt-3.3/plugins/inputmethods/libqxim.so:
  Plugin uses incompatible Qt library!
  expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux g++-4.*
full-config".
ScimInputContextPlugin()
Launched ok, pid = 2741
OggS-SEEK: at 0 want 60408 got 51136 (diff-requested 60408)
OggS-SEEK: at 60352 want 520 got 0 (diff-requested -59832)
Comment 4 Jens Petersen 2006-03-13 23:59:35 EST
Switching IME works ok with xim, the problem seems to be kbabel does
seem to like input with preedit.

Inscript and phonetic Indic input with scim-m17n basically seems to work ok.
Comment 5 Jens Petersen 2006-03-14 03:13:06 EST
er, that should read "...does *not* like input with preedit."
Comment 6 Akira TAGOH 2006-03-14 07:30:07 EST
It looks to me like a 64bit arch specific issue. this may be unlikely though, to
be sure, have you installed qt.x86_64? or this is more likely, how about the
file list of qt.x86_64? and does it contain the 64bit version of input method
plugins?

Those error messages are output when you run 32bit binary and 64bit binary
together IIRC. which version of Qt are you using?
Comment 7 Lawrence Lim 2006-03-15 00:57:19 EST
RE: Comment #6

You are right, I was using 64bit arch. :) I have qt-3.3.5-13 installed on my system.

# ls -la /usr/lib64/qt-3.3/plugins/inputmethods/
合計 504
drwxr-xr-x 2 root root   4096  1月 28  2005 .
drwxr-xr-x 5 root root   4096  1月 28  2005 ..
-rwxr-xr-x 1 root root  54528  2月 28  2006 libqimsw-multi.so
-rwxr-xr-x 1 root root  21656  2月 28  2006 libqimsw-none.so
-rwxr-xr-x 1 root root 148432  2月 12  2006 libqscim.so
-rwxr-xr-x 1 root root 159984  2月 28  2006 libqsimple.so
-rwxr-xr-x 1 root root  62976  2月 28  2006 libqxim.so
Comment 8 Lawrence Lim 2006-03-15 01:18:59 EST
Than,
Would you be able to give some insight from the KDE point of view, whether this
is a multilib issue?


Thanks.
Comment 9 Lawrence Lim 2006-03-15 02:38:20 EST
Additional Info:
Same problem exist on i386 machine as well. :/
Comment 10 Jens Petersen 2006-03-15 20:29:40 EST
I don't think multilib is the issue, the warnings in comment 3 always
happen on x86_64 the first time a kde (qt) app is run afaict (ie when
there is no "~/.qt/").

However input works ok for me on my FC4 workstation.  So could this
be related to changes in qt for fc5, Than?
Comment 11 Jens Petersen 2006-03-15 21:21:26 EST
I'm not able to input with uim-qt at all in kde apps
and uim xim can't commit Japanese in kbabel either in fc5.

Also Tagoh reported he had problems with kinput2 (xim).
Comment 12 Jens Petersen 2006-03-15 22:03:27 EST
BTW I tested scim-qtimm again with scim built without libstdc++so7
and it works ok with kedit, as does scim xim, but no luck with kbabel.
Comment 13 Jens Petersen 2006-03-16 00:54:46 EST
kbabel seems to work ok on RHEL4 too with scim-qtimm (and mostly with scim xim).
Comment 14 Jens Petersen 2006-03-16 04:01:27 EST
For FC4, input in kbabel seems to be ok with kdesdk-3.4.0-3/qt-3.3.4-14,
and also kdesdk-3.5.1-0.1.fc4/qt-3.3.4-15.4.
Comment 15 Jens Petersen 2006-03-22 09:10:16 EST
I built the current fc5 qt package with
qt-x11-immodule-unified-qt3.3.5-20060318.diff.bz2 but it doesn't seem to help.
Comment 16 Jens Petersen 2006-03-27 02:32:33 EST
Reverting qt to 3.3.4-15.4.x86_64 (from fc4!) makes kbabel input work ok for me.
Moving to qt.
Comment 17 Jens Petersen 2006-03-27 02:34:50 EST
(I also tried building fc4 qt for fc5, but so far I haven't succeeded.)
Comment 18 Jens Petersen 2006-03-27 23:25:08 EST
Still no better with qt-3.3.6-1, I'm afraid.
Comment 20 Jens Petersen 2006-04-03 23:57:35 EDT
Confirmed kinput2 doesn't work either under fc5.
Comment 21 Jens Petersen 2006-04-04 00:00:18 EDT
(with kbabel I mean, just to clarify)
Comment 23 Jens Petersen 2006-04-04 08:43:14 EDT
Also xim doesn't work with qt-3.3.6 built without the immodule patch.
Comment 24 Jens Petersen 2006-04-06 00:58:39 EDT
Nor qt-3.3.5 without the immodule patch either.
Comment 25 Jens Petersen 2006-04-06 04:01:43 EDT
qt-3.3.4 without the immodule patch on fc4 is also fine.
Comment 26 Jens Petersen 2006-04-06 06:01:49 EDT
A simple workaround is configure qt not to use on-the-spot IM fwiw.
Comment 28 Warren Togami 2006-05-22 13:16:01 EDT
than, any progress on this?  This is a pretty bad regression.
Comment 29 Ngo Than 2006-05-22 16:42:56 EDT
I did not find the scim and scim-qtimm for FC4? are both replacement for
iiimf in FC5? in case yes, could you please try to build qt >= 3.3.5 on FC4
and test if it works with iiimf? (please don't install any scim* packages here 
on FC4)

Does the problem only happen in kbabel?

I have tried with above steps from Lawrence Lim on FC5, but somehow i can only 
type alphabetic characters. How can i enable SCIM to write CJK?

It would be nice if you could give exactly steps to reproduce this problem. 
Thanks. 

infos: i cannot write and read any CJK language!
Comment 30 Warren Togami 2006-05-22 16:46:42 EDT
I don't think any of us have any FC4 desktops anymore, so we cannot quickly test
this.

In order to enable SCIM on FC5 in a non-CJK language, do this:
cd
mkdir .xinput.d
ln -s /etc/X11/xinit/xinput.d/scim-bridge default

The next time you login, SCIM should be enabled.

Note that the above bug indicates that this is not a SCIM specific problem, but
rather any IM that has preedit, so it also failed with XIM.
Comment 31 Ngo Than 2006-05-22 17:03:23 EDT
sorry, which package does include /etc/X11/xinit/xinput.d/scim-bridge ?

how can i type CJK with XIM?
Comment 32 Lawrence Lim 2006-06-14 06:29:31 EDT
Re: Comment #31

scim-bridge-0.1.8-17.i386.rpm under /dist/fc6/scim/1.4.4-17

hope it helps.
Comment 33 Jens Petersen 2006-06-14 08:01:04 EDT
(scim-bridge is now a separate package in FC devel.)

But this problem has nothing to do with scim or scim-qtimm.
It occurs with recent qt without scim or even without the qtimm patch...
ie even with qt upstream XIM.

More details can also be found on the immodule-qt list.
Comment 34 Jens Petersen 2006-06-20 02:54:46 EDT
Filed http://bugs.kde.org/show_bug.cgi?id=129468
upstream against kbabel.
Comment 35 Jens Petersen 2006-06-22 05:00:54 EDT
Hi Than, Just to answer all your questions:

(In reply to comment #29)
> I did not find the scim and scim-qtimm for FC4?

You can find them in Fedora Extras.

> are both replacement for iiimf in FC5?

Yes.

> in case yes, could you please try to build qt >= 3.3.5 on FC4
> and test if it works with iiimf? (please don't install any scim* packages here 
> on FC4)


> Does the problem only happen in kbabel?

Correct.

> I have tried with above steps from Lawrence Lim on FC5, but somehow i can only 
> type alphabetic characters. How can i enable SCIM to write CJK?

Actually it doesn't have to be CJK even: any preedit won't work.

You can also try: "yum install scim-m17n m17n-db-latin",
setup the symlink Warren described and restart the desktop.
Then open a .po file with kbabel and switch scim language to
Other -> M17N-t-Latn-pre (Latin prefix) and try to input say
'"a' to get "umlaut a" and you'll find the '"' which should put input
in preedit mode is completely ignored.  (Use the Help button on the
scim toolbar at the bottom-right of the screen for more info on keys.)
Before or after this please try the same in kedit say and note that
preedit input works fine.
Comment 36 Jens Petersen 2006-06-22 08:29:15 EDT
Sorry, forgot to answer this:

(In reply to comment #29)
> could you please try to build qt >= 3.3.5 on FC4
> and test if it works with iiimf?

As in comment 20, I already tested with kinput2
(an old Japanese XIM input method) and the problem is
the same there - hence the problem is not scim specific.

IIRC I couldn't get qt-3.3.5 to build on fc4 easily.  But I
think the above evidence I presented on fc5 (3.3.4 works but
not >=3.3.5) seems fairly conclusive.
Comment 37 Ngo Than 2006-06-23 12:50:49 EDT
Jens, many thanks for you info how to enable it. Now i want to verify this 
issue on FC4 with qt-3.3.4. I tried to install scim stuffs from FC5-extras, 
but i always crashes in libscim when i switched to chine input methode!

2 questions:
where can i find scim packages for FC4 which works with FC4?
which packages are needed so that i can test with kinput2?


Thanks
Comment 38 Jens Petersen 2006-06-26 03:25:37 EDT
(In reply to comment #37)
> where can i find scim packages for FC4 which works with FC4?

They are in Fedora Extras.

> which packages are needed so that i can test with kinput2?

"yum install kinput2" should give you enough to test preedit. :)
Comment 39 Jens Petersen 2006-06-26 03:26:31 EDT
(Just to clarify: kinput2 is also in Extras.)
Comment 40 Jens Petersen 2006-06-27 04:50:50 EDT
FYI I just tried qt-3.3.5-10 on my fc5 testbox and the problem
occurs with that package too.
Comment 41 Ngo Than 2006-06-27 05:57:45 EDT
Jens, i have installed the scim packages from FC4-Extras. When i switches to 
CJK input methode, it crashes in scim! It seems the scim and scim-tables 
packages are broken. Scim works fine in FC6 rawhide but not in FC4/FC5!

Does the scim stuff from FC4 Extras work for you? How can i get scim working
in FC4 adn FC5?

Thanks
Comment 42 Jens Petersen 2006-06-27 07:31:33 EDT
Disabling 0056-khotkeys_input_84434.patch didn't help either.

I also tried comparing src/kernel/qapplication_x11.cpp of 3.3.4
and 3.3.5 but couldn't really see anything obvious.
Comment 43 Jens Petersen 2006-06-27 07:39:55 EDT
(In reply to comment #41)
> Jens, i have installed the scim packages from FC4-Extras. When i switches to 
> CJK input method, it crashes in scim! It seems the scim and scim-tables 
> packages are broken. Scim works fine in FC6 rawhide but not in FC4/FC5!

scim is working fine in fc5 and fc4 afaik.

> Does the scim stuff from FC4 Extras work for you?

Yes it works just fine for me.
I have scim{,-libs}-1.4.4-1.fc4.x86_64 and scim-anthy installed.

What packages are you using?
Comment 44 Jens Petersen 2006-06-27 07:40:21 EDT
Why are you using scim-tables?
Comment 45 Jens Petersen 2006-06-27 07:41:52 EDT
As I suggested in comment 35 you may find it easier to test
with scim-m17n and m17n-db-latin say.
Comment 46 Jens Petersen 2006-06-27 10:30:19 EDT
I also tried reverting src/kernel/qapplication_x11.cpp to the version in
3.3.4 for the latest fc5 update but this did not help either.
Comment 47 Ngo Than 2006-06-28 14:05:33 EDT
Jens, could you please try new qt-3_3_6-9 in rawhide if this fixes this issue?

Thanks
Comment 48 Ngo Than 2006-06-29 02:36:54 EDT

*** This bug has been marked as a duplicate of 196114 ***
Comment 49 Jens Petersen 2006-07-02 05:00:01 EDT
*** Bug 196114 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.