Bug 1835094 - Collect Anonymized CSR (release-4.3)
Summary: Collect Anonymized CSR (release-4.3)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Martin Kunc
QA Contact: Angelina Nikiforova
Radek Vokál
URL:
Whiteboard:
Depends On: 1834677 1835090 1835093 1836815
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 05:44 UTC by Martin Kunc
Modified: 2020-06-17 20:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Added collection anonymized unapproved Certificate Service Requests. Reason: We want to see if Certificates which are denied, expired or not valid yet at least in their anonymized form. Theys could be a good clue to solve customer issues. Result:
Clone Of: 1835093
Environment:
Last Closed: 2020-06-17 20:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2436 None None None 2020-06-17 20:28:16 UTC

Description Martin Kunc 2020-05-13 05:44:45 UTC
+++ This bug was initially created as a clone of Bug #1835093 +++

+++ This bug was initially created as a clone of Bug #1835090 +++

Description of problem:
The task should add collection of Certificate features, which could be used to verify their validity in further stages.


Version-Release number of selected component (if applicable):
4.5

How reproducible:
Look into Insights operator archive for CSR. They are missing.

Steps to Reproduce:
1. Install OCP with some unapproved Certificate signing requests. 
2. Let Insighst Operator collect archive and 
3. look inside to check 

Actual results:
No CSR data

Expected results:
Anonymized CSR exists

Additional info:

Comment 4 Angelina Nikiforova 2020-06-05 14:03:16 UTC
Fixed and verified in 4.3.0-0.nightly-2020-06-05-071243

Comment 6 errata-xmlrpc 2020-06-17 20:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2436


Note You need to log in before you can comment on or make changes to this bug.