Bug 183699 - (qt XIM) scim XIM interface fails after some runtime
(qt XIM) scim XIM interface fails after some runtime
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC6Blocker SCIM FC5Update
  Show dependency treegraph
 
Reported: 2006-03-02 16:26 EST by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 07:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-03-02 16:26:37 EST
XMODIFIERS=@im=SCIM
QT_IM_MODULE=xim

Due to Bug #182177 we are currently using these environment variables in FC5 in
order to fallback to XIM for qt/KDE input until we can fix scim-qtimm.  This
seems to work fine immediately after logging into my GNOME desktop session with
apps like Konqueror or Skype (both qt apps), but after a few hours of using my
desktop, all qt apps fail to start with messages like this:

[warren@caprica ~]$ konqueror
kbuildsycoca running...
Failed to create XIM input context!

I suspect that this is actually a qt-specific problem and not scim's XIM
interface, because I am able to use XIM with gtk applications when qt apps fail
to start in my desktop session.  Assigning to qt unless proven otherwise.
Comment 1 Warren Togami 2006-05-10 17:01:28 EDT
Jens, could Bug #183302 be the cause of this issue?
Comment 2 Jens Petersen 2006-05-10 21:13:55 EDT
Possibly related, though the symptoms seem to be different.

It would be interesting to know whether this can be reproduced on FC4 or not.
Comment 3 Leon Ho 2006-05-31 23:35:16 EDT
I often encounter this problem even though the input method is not activated.
This is definitely a big issue for providing basic inputting in KDE/Qt
environment. Setting severity as high.
Comment 4 Jong Bae KO 2006-06-15 02:02:13 EDT
------- Additional Comments From than@redhat.com  2006-06-09 07:02 EST -------
I cannot reproduce this problem with above steps with current rawhide.
It would be helpful for debugging if someone could gives the test case which
i can always reproduce this problem.
Comment 5 Jong Bae KO 2006-06-15 02:10:26 EDT
------- Additional Comments From wtogami@redhat.com  2006-06-09 12:08 EST -------
There are no steps... it seems to happen only after many hours of runtime during
a GNOME desktop session.  Although I am running FC5.

Leon, you are running Rawhide and you can reproduce this?
Comment 6 Ngo Than 2006-06-23 07:08:36 EDT
could someone reproduce this issue in rawhide. I have tried
with above steps since 5 days and still cannot reproduce this.

I assume it's fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.