Bug 1837934 - PV-pool yaml is missing requested storage when created from UI
Summary: PV-pool yaml is missing requested storage when created from UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Ankush Behl
URL:
Whiteboard:
Depends On:
Blocks: 1837995 1838420
TreeView+ depends on / blocked
 
Reported: 2020-05-20 08:39 UTC by afrahman
Modified: 2020-07-13 17:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1837995 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:40:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
Backing store for default size (312 bytes, text/plain)
2020-05-21 07:47 UTC, Ankush Behl
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5499 None closed Bug 1837934: Fix Backing Store creation request 2020-08-06 16:57:07 UTC
Github openshift console pull 5512 None closed Bug 1837934: Fix default value different from state 2020-08-06 16:57:07 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:40:56 UTC

Description afrahman 2020-05-20 08:39:56 UTC
Description of problem:
PV-pool yaml is missing requested storage when created from UI

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
Install OCS operator on OCP

Steps to Reproduce:
1.Go to OCS operator
2.Click on backing store
3.Select provider as PVC.
4.Enter the size
5.Check yaml

Actual results:
The PV-pool yaml is missing the storage size mentioned on form

Expected results:
The PV pool form must reflect the requested storage in yaml and pass it to the operator.

Additional info:

Comment 3 Ankush Behl 2020-05-21 07:47:09 UTC
Created attachment 1690543 [details]
Backing store for default size

Comment 5 Ankush Behl 2020-05-27 10:58:37 UTC
Verified. The request is coming properly now.

```
spec:
  pvPool:
    numVolumes: 1
    resources:
      requests:
        storage: 50Gi
    storageClass: gp2
  ssl: false
  type: pv-pool
```

OpenShift Version: 4.5.0-0.nightly-2020-05-27-000432
Kubernetes Version: v1.18.2+9835af5

Comment 6 errata-xmlrpc 2020-07-13 17:40:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.