Bug 1841057 - After the start the upload of results shouldn't be delayed
Summary: After the start the upload of results shouldn't be delayed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Martin Kunc
QA Contact: Angelina Nikiforova
Radek Vokál
URL:
Whiteboard:
Depends On:
Blocks: 1841058 1841059 1841064 1842489 1855212
TreeView+ depends on / blocked
 
Reported: 2020-05-28 09:05 UTC by Martin Kunc
Modified: 2020-08-27 04:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1841058 1855212 1855240 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:42:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift insights-operator pull 117 0 None closed Bug 1841057: Skip the initial upload delay 2020-10-26 10:16:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:44 UTC

Description Martin Kunc 2020-05-28 09:05:27 UTC
Description of problem:
Currently for protection against thundering herd the upload of collected data is delayed (15-30 min) of 2h collecting interval. We would like to get first data sooner, so if the IO is starting for first time, or when it is running successfully, initial upload wont be delayed.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
After the installation the IO archive appears in DataHub too late.

Steps to Reproduce:
1. Install OC
2. Keep checking DataHub support shell folder


Actual results:
Archive was created with significant delay ~50 min.

Expected results:
Archive should be there as soon as possible.

Additional info:

Comment 3 Angelina Nikiforova 2020-06-02 08:02:13 UTC
Fixed and verified in 4.5.0-0.nightly-2020-06-02-044312

I0602 07:24:33.609983       1 insightsuploader.go:87] Reporting status periodically to https://cloud.redhat.com/api/ingress/v1/upload every 2h0m0s, starting in 0s
...
I0602 07:24:49.667517       1 insightsclient.go:214] Successfully reported id=2020-06-02T07:24:48Z x-rh-insights-request-id=17a26aa845604c17b1f443f04f2f6f23, wrote=42699

Comment 4 errata-xmlrpc 2020-07-13 17:42:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.