Bug 1843552 - Edit application grouping is displayed as the first VM action
Summary: Edit application grouping is displayed as the first VM action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.5.z
Assignee: Jeff Phillips
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 1842857
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-03 14:18 UTC by OpenShift BugZilla Robot
Modified: 2020-07-30 18:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5662 None closed [release-4.5.z] Bug 1843552: Only show Edit Grouping action for VMs in topology view 2020-07-29 12:27:54 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:18 UTC

Description OpenShift BugZilla Robot 2020-06-03 14:18:14 UTC
+++ This bug was initially created as a clone of Bug #1842857 +++

Created attachment 1694351 [details]
screenshot

Description of problem:
VM action dropdown has 'Edit application grouping' action displayed as the first option.



Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1. Open VM action dropdown

--- Additional comment from yzamir@redhat.com on 2020-06-02 13:02:22 UTC ---

Targeting 4.6, this looks very high profile, we may consider backporting

--- Additional comment from yzamir@redhat.com on 2020-06-02 15:34:50 UTC ---

Note:

I think it was added by mistake with the fix for
https://bugzilla.redhat.com/show_bug.cgi?id=1835170

--- Additional comment from yzamir@redhat.com on 2020-06-02 15:39:57 UTC ---

Note II:
a - Sorry, not added, just moved to the top (merged 5 days ago):
    https://github.com/openshift/console/pull/5603/files#diff-e1ea60ed2e820073acdfd59753ed6636R211

b - Asked on https://bugzilla.redhat.com/show_bug.cgi?id=1835170 if this is intentional.
    Will update here when get answer.

--- Additional comment from yzamir@redhat.com on 2020-06-02 15:54:49 UTC ---

Thanks Jeff

Comment 1 Tomas Jelinek 2020-07-10 05:39:44 UTC
patch ready, just waiting for 4.5.z to open to be merged.

Comment 5 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.