Bug 1842875 - Normal user can not view Metrics details on dev console
Summary: Normal user can not view Metrics details on dev console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Vikram Raj
QA Contact: spathak@redhat.com
URL:
Whiteboard:
: 1843814 (view as bug list)
Depends On:
Blocks: 1846409 1852757
TreeView+ depends on / blocked
 
Reported: 2020-06-02 09:48 UTC by Yadan Pei
Modified: 2020-10-27 16:04 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Normal user with no access to list the all the namespace is not able to see the Metrics details in Dev Console Consequence: Unable to see the details of the metrics present on the Cluster Utilization card on the Overview page. Fix: Remove the checks if user have access to list the all namespace to access the metrics page in Dev console. Result: Normal user is able to view Metrics details on dev console
Clone Of:
: 1852757 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Normal user can view Metrics details on dev console (664.43 KB, video/webm)
2020-06-23 21:25 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5661 0 None closed Bug 1842875: Remove the checks CAN_GET_NS and prometheusBaseURL for monitoring Dashboard and Metrics tabs in devconsole 2020-10-12 16:25:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:04:20 UTC

Description Yadan Pei 2020-06-02 09:48:38 UTC
Description of problem:
normal user can not view metrics more details and blank page returned

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-06-01-165039

How reproducible:
Always

Steps to Reproduce:
1. normal user create application from builder image on console
2. wait application pod is running and metrics data is loaded 
3. Home -> Projects -> click on user project -> click on any chart in Utilization card

Actual results:
3. user is taken to dev console Monitoring page, a blank page is shown without any metrics data

Expected results:
3. metrics data is shown correctly

Additional info:

Comment 3 Abhishek K N 2020-06-04 17:54:40 UTC
*** Bug 1843814 has been marked as a duplicate of this bug. ***

Comment 8 spathak@redhat.com 2020-06-23 21:25:53 UTC
Created attachment 1698504 [details]
Normal user can view Metrics details on dev console

Comment 9 spathak@redhat.com 2020-06-23 21:33:30 UTC
Validated on build version: 4.6.0-0.nightly-2020-06-23-093311
Browser version: Chrome76

Comment 11 errata-xmlrpc 2020-10-27 16:03:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.