Bug 1845825 - thanos-ruler route is not removed after disabled techPreviewUserWorkload
Summary: thanos-ruler route is not removed after disabled techPreviewUserWorkload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Sergiusz Urbaniak
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks: 1853257 1853496
TreeView+ depends on / blocked
 
Reported: 2020-06-10 07:34 UTC by hongyan li
Modified: 2020-10-27 16:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1853257 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 814 0 None closed Bug 1845825: Cleanup thanos ruler route when user workload monitoring is disabled 2020-10-21 08:48:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:06:38 UTC

Description hongyan li 2020-06-10 07:34:16 UTC
Description of problem:
resoure route.route.openshift.io/thanos-ruler exists under openshift-user-workload-monitoring after disable techPreviewUserWorkload 

# oc get all -n openshift-user-workload-monitoring
NAME                                    HOST/PORT                                                                                            PATH   SERVICES       PORT   TERMINATION          WILDCARD
route.route.openshift.io/thanos-ruler   thanos-ruler-openshift-user-workload-monitoring.apps.hongyali-aws-6-10.qe.devcluster.openshift.com          thanos-ruler   web    reencrypt/Redirect   None

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-06-09-223121

How reproducible:
always

Steps to Reproduce:
1.Enable techPreviewUserWorkload
2.Disable techPreviewUserWorkload by edit configmap and set techPreviewUserWorkload "enabled: false" or delete the whole configmap
3. execute 'oc get all -n openshift-user-workload-monitoring'

Actual results:
thanos-rule route exists

Expected results:
No route exist under name space openshift-user-workload-monitoring

Additional info:

Comment 6 hongyan li 2020-06-29 07:05:42 UTC
Set up environment with payload:
1.Enable techPreviewUserWorkload
2.Disable techPreviewUserWorkload by edit configmap and set techPreviewUserWorkload "enabled: false" or delete the whole configmap
3. execute 'oc get all -n openshift-user-workload-monitoring', get message "No resources found in openshift-user-workload-monitoring namespace."

Comment 7 hongyan li 2020-06-29 07:07:31 UTC
verified with payload: 4.6.0-0.nightly-2020-06-26-035408

Comment 10 errata-xmlrpc 2020-10-27 16:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.