Bug 1853496 - thanos-ruler route is not removed after disabled techPreviewUserWorkload
Summary: thanos-ruler route is not removed after disabled techPreviewUserWorkload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.z
Assignee: Simon Pasquier
QA Contact: hongyan li
URL:
Whiteboard:
: 1853257 (view as bug list)
Depends On: 1845825
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-02 19:48 UTC by OpenShift BugZilla Robot
Modified: 2020-08-17 20:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-17 20:05:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 840 None closed [release-4.5] Bug 1853496: Cleanup thanos ruler route when user workload monitoring is disabled 2020-08-17 01:15:49 UTC
Red Hat Product Errata RHBA-2020:3330 None None None 2020-08-17 20:05:42 UTC

Comment 1 Paul Gier 2020-07-02 19:52:39 UTC
*** Bug 1853257 has been marked as a duplicate of this bug. ***

Comment 6 Junqi Zhao 2020-08-10 03:44:41 UTC
tested with 4.5.0-0.nightly-2020-08-09-071700, thanos-ruler route is removed after disabling techPreviewUserWorkload.

# oc -n openshift-user-workload-monitoring get route
No resources found in openshift-user-workload-monitoring namespace.

Comment 8 errata-xmlrpc 2020-08-17 20:05:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3330


Note You need to log in before you can comment on or make changes to this bug.