Bug 1846863 - No response when creating operator instance using “Configure via: Form View”
Summary: No response when creating operator instance using “Configure via: Form View”
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1853182 1853274
TreeView+ depends on / blocked
 
Reported: 2020-06-15 07:13 UTC by Wei Duan
Modified: 2020-10-27 16:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Catch logic for failed operand form submit was attempting to access a deep property in the resulting error object that is not always defined. Consequence: For specific failed request types, this would cause a runtime error. Fix: Update the catch logic for operand form submit failures to always use `error.message`, and fallback to Result:
Clone Of:
: 1853182 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5737 None closed Bug 1846863: Fix runtime error on legacy operand form 2020-10-23 20:46:00 UTC
Red Hat Product Errata RHBA-2020:4196 None None None 2020-10-27 16:07:22 UTC

Description Wei Duan 2020-06-15 07:13:47 UTC
Description of problem:
No response when creating operator instance using Configure via: Form View

Version-Release number of selected component (if applicable):
[wduan@MINT appregistry]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-11-183238   True        False         136m    Cluster version is 4.5.0-0.nightly-2020-06-11-183238

How reproducible:
Always

Steps to Reproduce:
0. Create operatorsource using following yaml file
[wduan@MINT appregistry]$ more 02_operatorsource.yaml
apiVersion: operators.coreos.com/v1
kind: OperatorSource
metadata:
  name: manila-app-registry
  namespace: openshift-marketplace
spec:
  type: appregistry
  endpoint: https://quay.io/cnr
  registryNamespace: rh-osbs-operators
  authorizationToken:
    secretName: qesecret

1.From webconsole, install CSI Drvier Manila Operator
2.Install ManilaDriver instance by Operator-Installed Operator-CSI Drvier Manila Operator-Create Instance
3.Choosing "Form View" as "Configure via" (by default) and click "Create"  button

Actual results:
No response and no ManilaDriver instance is created
Uncaught error 
unhandledrejection { target: Window, isTrusted: true, promise: Promise { "rejected" }, reason: TypeError, srcElement: Window, currentTarget: Window, eventPhase: 2, bubbles: false, cancelable: true, returnValue: true, … }
 main-chunk-de4ff261cc3bde5ad14a.min.js:1
    onunhandledrejection main-chunk-de4ff261cc3bde5ad14a.min.js:1
TypeError: e.json is undefined  create-operand-chunk-8f7c184d9f0ade7a8b16.min.js:1    

Expected results:
ManilaDriver instance created successfully.

Additional info:
When choosing "YAML View" as "Configure via", it works.

Comment 1 Jon Jackson 2020-06-15 16:23:04 UTC
Wei, I am unable to reproduce because I can't get the CSI Driver Manila operator to populate in OperatorHub using your instructions/yaml. My guess is that there's a problem with the authorizationToken.

Comment 4 Jon Jackson 2020-06-18 19:27:05 UTC
https://github.com/openshift/console/pull/5737

Awaiting PR review and merge.

Comment 7 Yadan Pei 2020-06-29 07:28:09 UTC
1. Create OperatorSource using the yaml in description
2. Install Manila CSI Driver Operator from Operator Hub
3. Create Operand `Manila Driver` with Form View, manila driver instance can be created successfully

Verified on 4.6.0-0.nightly-2020-06-26-035408

Comment 9 errata-xmlrpc 2020-10-27 16:06:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.