Bug 1853274 - No response when creating operator instance using “Configure via: Form View”
Summary: No response when creating operator instance using “Configure via: Form View”
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1853182 (view as bug list)
Depends On: 1846863
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-02 10:29 UTC by OpenShift BugZilla Robot
Modified: 2020-07-30 18:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Catch logic for failed operand form submit was attempting to access a deep property in the resulting error object that is not always defined. Consequence: For specific failed request types, this would cause a runtime error. Fix: Update the catch logic for operand form submit failures to always use `error.message`, and fallback to Result:
Clone Of:
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (1.02 MB, video/quicktime)
2020-07-23 06:18 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5878 None closed Bug 1853274: Fix runtime error on legacy operand form 2020-08-24 03:45:58 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:33 UTC

Comment 1 Scott Dodson 2020-07-02 12:29:01 UTC
*** Bug 1853182 has been marked as a duplicate of this bug. ***

Comment 4 XiaochuanWang 2020-07-23 06:18:00 UTC
Created attachment 1702160 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-07-23 06:18:57 UTC
This instance could be created successfully (attached the screen recording for refer)
Verified on 4.5.0-0.nightly-2020-07-23-023500

Comment 7 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.