Bug 18478 - gpm freaks with MS IntelliMouse
gpm freaks with MS IntelliMouse
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 23494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 18:42 EDT by Joshua Jensen
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 23:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2000-10-05 18:42:51 EDT
gpm doesn't work with a defined mouse type of MS IntelliMouse on my Dell
5000 laptop.  Not sure if it is fighting with the built in mouse or not
(don't think so).  The way around this is to tell X in XF86Config that I
have an IntelliMouse, and in /etc/sysconfig/mouse indicate a 3 button
PS/2.  It would be nice if the truth (MS IntelliMouse) worked
out-of-the-box.
Comment 1 Preston Brown 2001-01-31 17:32:06 EST
you are saying you have externally plugged in a PS/2 MS Intellimouse, right? And
you have a built-in mouse as well?
Comment 2 Joshua Jensen 2001-02-01 01:24:46 EST
yes, that is what I am saying
Comment 3 Joshua Jensen 2001-02-01 09:45:53 EST
I just verified that beta3 still has this problem.  It seems that gpm can't take
the "Microsoft - IntelliMouse (PS/2)" kind of mouse.  Cut and paste fails badly
on the console, but works perfectly in X.  I saved my /etc/sysconfig/mouse to
mouse.bak, then re-ran mouseconfig, and it gives me a mouse of type
"Microsoft IntelliMouse (PS/2)".  gpm still doesn't work after "service gpm
restart", so this may be two bugs in one:  gpm with InelliMice, and
mouseconfig -vs- the installer.
Comment 4 Preston Brown 2001-02-08 19:15:49 EST
*** Bug 23494 has been marked as a duplicate of this bug. ***
Comment 5 Preston Brown 2001-04-06 13:39:06 EDT
gpm 1.19.3-7 and later read a DEVICE line (if present) from 
/etc/sysconfig/mouse, and use that as an argument to gpm's -m option.

mouseconfig-4.21 and later write this line, defaulting to "/dev/mouse", the 
symlink it makes to the actual device.

Comment 6 Preston Brown 2001-04-06 13:40:52 EDT
whoops, this was supposed to be a comment on bug 23500, sorry.
Comment 7 Preston Brown 2001-06-25 13:22:32 EDT
Josh:

Are you still having problems with your intellimouse and gpm in 7.1 as released?  
We aren't having problems here in our lab.

This may actually be a kernel issue...
Comment 8 Joshua Jensen 2001-06-26 23:37:50 EDT
Still having the same problems with my external mouse. I've updated to
mouseconfig-4.22-1 and kernel 2.4.3-12, and I can't choose the MS Intellimouse
and get gpm to work. It freaks out and places the cursor in the top-right part
of the screen while randomly cutting and pasting anything on the screen. My
procedure:

service gpm stop
rm -f /etc/sysconfig/mouse
mouseconfig  
        (choose MS Intellimouse PS2) 
        (choose to update X config's mouse section)
service gpm start

This gives the gpm malfunction as described above, yet X works perfectly
and can use scroll-wheel functionality.  To solve the gpm problems, I am still
forced to additional perform the following:

service gpm stop
mouseconfig  
        (choose Generic 3 button PS2)
        (choose *NOT* to update X config's mouse section)
service gpm start

This works... X has the MS Intellimouse features, and gpm thinks it has 
the wheel as the middle button of a Generic 3 button PS/2.

Still, it shouldn't be this way.  I wonder if my built in touchpad mouse is
somehow causing gpm to act strangly?  I doubt it, as it doesn't work in X or
with gpm when I have my external generic MS Intellimouse plugged in.
Comment 9 Joshua Jensen 2001-07-18 10:22:59 EDT
I've got strange mouse hardware, which seems to be the problem.  I'll close the
bug.  Thank you Preston for spending the time on this one.

JOshua

Note You need to log in before you can comment on or make changes to this bug.