Bug 23500 - GPM on devfs partial fix
Summary: GPM on devfs partial fix
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 34883 (view as bug list)
Depends On:
Blocks: 23499
TreeView+ depends on / blocked
 
Reported: 2001-01-07 04:57 UTC by Andrew Bartlett
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 00:34:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for init.d/gpm to use a DEVICE variable and make it usable on devfs (363 bytes, patch)
2001-01-07 05:01 UTC, Andrew Bartlett
no flags Details | Diff
A better version of the above patch, for use with mouseconfig.c patch on bug 235499 (368 bytes, patch)
2001-01-07 08:21 UTC, Andrew Bartlett
no flags Details | Diff

Description Andrew Bartlett 2001-01-07 04:57:33 UTC
This is the gpm owned part of my fix to bug 22810 and bug 23499.  

It uses a new entry in the configuraion file to define the location of the
mouse, rather than using /dev/mouse which is missing on devfs.

Comment 1 Andrew Bartlett 2001-01-07 05:01:57 UTC
Created attachment 7165 [details]
patch for init.d/gpm to use a DEVICE variable and make it usable on devfs

Comment 2 Andrew Bartlett 2001-01-07 08:21:44 UTC
Created attachment 7168 [details]
A better version of the above patch, for use with mouseconfig.c patch on bug 235499

Comment 3 Preston Brown 2001-04-06 17:41:14 UTC
gpm 1.19.3-7 and later read a DEVICE line (if present) from 
/etc/sysconfig/mouse, and use that as an argument to gpm's -m option.

mouseconfig-4.21 and later write this line, defaulting to "/dev/mouse", the 
symlink it makes to the actual device.




Comment 4 Preston Brown 2001-04-06 17:41:22 UTC
*** Bug 34883 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.