Bug 1850344 - Operators won't install if the CSV dependency is already installed
Summary: Operators won't install if the CSV dependency is already installed
Keywords:
Status: CLOSED DUPLICATE of bug 1850632
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1850619
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 06:20 UTC by Jian Zhang
Modified: 2020-06-25 16:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-25 16:55:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jian Zhang 2020-06-24 06:20:30 UTC
----This bug is a clone of bug 1849164 ----

Description of problem: 

We have an operator with CSV dependencies. When we install it, we expect OLM to install the dependencies as well. However, if the dependencies are already in a namespace, the operator won't install.

We have to delete the dependent operators in order to install the operator.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: Failed to install the operator because of dependencies being already installed


Expected results: Should be easily installed if it already exists.


Additional info:

   PrivateComment 1Jaspreet Kaur 2020-06-19 18:07:40 UTC
RED HAT CONFIDENTIAL
Created attachment 1698140 [details]
install plan

Jaspreet Kaur 2020-06-19 18:07:56 UTC
Priority: unspecified → high
   PrivateComment 2Jaspreet Kaur 2020-06-19 18:47:45 UTC
RED HAT CONFIDENTIAL
Created attachment 1698149 [details]
logs

   PrivateComment 3Jaspreet Kaur 2020-06-19 18:49:45 UTC
RED HAT CONFIDENTIAL
We also see below logs :

I see: E0619 17:58:35.712165       1 queueinformer_operator.go:290] sync {"update" "openshift-operators/install-c4pm7"} failed: failed to update installplan bundle lookups: rpc error: code = ResourceExhausted desc = trying to send message larger than max (2268082 vs. 2097152)

Vladislav Walek 2020-06-19 19:05:12 UTC
Link ID: Red Hat Customer Portal 02657441
Vladislav Walek 2020-06-19 19:05:34 UTC
Priority: high → urgent
CC: vwalek@redhat.com
Severity: high → urgent
Vladislav Walek 2020-06-19 19:14:11 UTC
Link ID: Red Hat Customer Portal 02683499
   PrivateComment 4Vladislav Walek 2020-06-19 22:28:31 UTC
RED HAT CONFIDENTIAL
just adding the update from customer:

Q: 1. Which is the main operator and dependent operator you are referring to. So Engineering can try to reproduce it if possible.

A: Cloud Pak for Integration Operator, we haven't published it yet. We depend on ~9-11 operators that are part of the product.


Q: 2.  Also, output for command - "oc get subscriptions -n <namespace>"
$ oc get subscriptions
NAME                 PACKAGE              SOURCE           CHANNEL
ibm-cp-integration   ibm-cp-integration   cp-integration   v1.0


The clusterid is "6e856bf2-12b0-43f7-8a7b-899fbf1e0857".

   PrivateComment 5Evan Cordell 2020-06-20 13:49:13 UTC
RED HAT CONFIDENTIAL
> failed to update installplan bundle lookups: rpc error: code = ResourceExhausted desc = trying to send message larger than max (2268082 vs. 2097152)

This error suggests that the total set of resolved manifests to install is larger than can fit in a single resource for the cluster. We do not currently have a good workaround for this case, we will discuss and get back to this.

(The primary issue reported in the top-level bug does not seem accurate)

Keywords: UpcomingSprint
   PrivateComment 6Stephen Cuppett 2020-06-22 12:10:22 UTC
Setting target release to current development version (4.6) for investigation. Where fixes (if any) are required/requested for prior versions, cloned BZs will be created when appropriate.

Comment 1 Dan Geoffroy 2020-06-25 16:55:19 UTC

*** This bug has been marked as a duplicate of bug 1850632 ***


Note You need to log in before you can comment on or make changes to this bug.