This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 185319 - Yelp fails to show man pages
Yelp fails to show man pages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 186023 194312 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 13:14 EST by Brian Wheeler
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 11:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yelp error message (11.13 KB, image/png)
2006-04-01 04:17 EST, Igor Jagec
no flags Details
yelp error message (11.13 KB, image/png)
2006-04-01 04:18 EST, Igor Jagec
no flags Details
yelp error message (11.13 KB, image/png)
2006-04-01 04:18 EST, Igor Jagec
no flags Details

  None (edit)
Description Brian Wheeler 2006-03-13 13:14:36 EST
Description of problem:

Trying to view a manpage fails with this message:

Could not load document
The Uniform Resource Identifier 'man:perl(1)' is invalid or does not point to an
actual file.


Version-Release number of selected component (if applicable):
yelp-2.13.6-1

How reproducible:
Every time

Steps to Reproduce:
1. search for perl
2. click on 'perl manual page'
3. witness the dialog box
  
Actual results:

page not shown, error message displayed.

Expected results:

The manpage in question

Additional info:
Comment 1 Igor Jagec 2006-04-01 04:17:55 EST
Created attachment 127171 [details]
yelp error message

It still fails to view man pages, as you can see in the attachment.
Comment 2 Igor Jagec 2006-04-01 04:18:06 EST
Created attachment 127172 [details]
yelp error message

It still fails to view man pages, as you can see in the attachment.
Comment 3 Igor Jagec 2006-04-01 04:18:19 EST
Created attachment 127173 [details]
yelp error message

It still fails to view man pages, as you can see in the attachment.
Comment 4 petrosyan 2006-06-16 18:49:48 EDT
this bug is still present in Fedora Core 5.
yelp-2.14.2-1
please update your bugreport
Comment 5 Matthew Barnes 2006-08-23 14:44:18 EDT
*** Bug 186023 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Barnes 2006-08-23 14:45:07 EDT
*** Bug 194312 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Barnes 2006-08-23 15:42:58 EDT
Can someone check whether this bug is still present in yelp-2.14.3-1.fc5?

Manual page URLs in yelp seem to be successfully opening for me.
Comment 8 Ilya Ryabinkin 2006-08-26 04:05:44 EDT
yelp.i386                                2.14.3-1.fc5           installed

[ilya@node6 ~]$ yelp --version
Gnome yelp 2.14.3
[ilya@node6 ~]$ uname -a
Linux node6.chem.msu.ru 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686
i686 i386 GNU/Linux

Bug is still present with the same symptoms.
Comment 9 Matthew Barnes 2006-08-27 22:43:11 EDT
I'm still unable to reproduce this on an up-to-date Fedora Core 5.

Scanning the dependencies, here's a few other packages which may be relevant. 
Kindly check the package versions on your machine.

mozilla-1.7.13-1.1.fc5
gnome-doc-utils-0.6.0-1
scrollkeeper-0.3.14-5.2.1

Are you able to open manual pages through Yelp by manually navigating to them? 
From the "Help Topics" pages, select "Command Line Help" -> "Manual Pages" and
try a few of the links there.
Comment 10 Ilya Ryabinkin 2006-08-29 07:01:37 EDT
[ilya@node6 ~]$ rpm -q mozilla
mozilla-1.7.13-1.1.fc5
[ilya@node6 ~]$ rpm -q gnome-doc-utils
gnome-doc-utils-0.6.0-1
[ilya@node6 ~]$ rpm -q scrollkeeper
scrollkeeper-0.3.14-5.2.1
Yes, I'm able to open manual pagese using "Command Line Help" -> "Manual Pages"
route. That is no problem. The problem is actual if I try the following:
1. Search for a particular page, e.g. i810
2. Clicked to the found hyperlink "i810 manual page" I receive
      Error

The Uniform Resource Identifier 'man:i810
(4)' is invalidor does not point to an actual file.

[ilya@node6 ~]$ yelp man:i810
works as expected (displayed manual page)
Comment 11 Matthew Barnes 2006-10-25 12:39:52 EDT
As of yesterday, yelp 2.14 is no longer supported in Fedora Core 5.
Can you please try again with yelp 2.16 in Fedora Core 6?
Comment 12 Brian Wheeler 2006-10-25 12:49:39 EDT
Search in yelp doesn't find man pages in FC6.  Is there something I need to do
to index them?

Viewing the page via CTRL-L  "man:perl" displays ok, so the problem may be fixed
(I don't have an FC5 to test it on)
Comment 13 Matthew Barnes 2006-10-25 13:16:52 EDT
It seems yelp only displays the first page of matches.  Searching for "man:perl"
goes there straightaway, though (no need to use the Ctrl-L shortcut).

Searching for "grep", for example, does show the manual page in the search
results.  In fact it shows _three_ manual page entries for grep.  The first link
works fine ("man:grep"), but the others are trying to open "man:grep(1p)" and
"man:grep(rpm)" and produce the same error as originally reported.
Comment 14 Brian Wheeler 2006-10-25 13:39:23 EDT
Is the "first page only" a bug or a feature?  If its a bug, should I submit it?

Oddly, my FC6 (which was an upgrade from FC5) doesn't show the man pages in yelp
for grep:
--------------
Chapter 5. Making Happy Users
Grep
        from file:///usr/share/doc/HTML/en/kdevelop/editing.docbook
Chapter 3. Secure Office Networking
file:///usr/share/doc/git-core-1.4.2.4/git-grep.html
Chapter 7. Adding Domain Member Servers and Clients
file:///usr/share/doc/samba-3.0.23c/htmldocs/using_samba/ch02.html
Chapter 15. A Collection of Useful Tidbits
Tips And Tricks For The Emacspeak Audio Desktop
fish user documentation
kate: kateprinter.cpp Source File (kate)
--------------------
Comment 15 Matthew Barnes 2006-10-25 13:55:30 EDT
It probably depends on what else you have installed on your system.  Maybe try a
few other command-line tools.  I get manual page results for "awk" and "gcc".

Asking for additional pages of matches is probably a feature request.  Your best
bet is to ask the upstream developers at http://bugzilla.gnome.org/.
Comment 16 Brian Wheeler 2006-10-25 14:10:37 EDT
I'm not getting them.  When I do a search for "umount", which should be pretty
unique, I don't get any man pages, but I get the HTML version of them from the
/usr/share/doc/samba* directory.  Sometimes I get things which look like man
pages  (history as a search term, for example), but I'm actually getting the
HTML-ized documentation from /usr/share/doc (In this case, the BASH(1) page from
file:///usr/share/doc/bash-3.1/bash.html)

Maybe I just haven't waited long enough for beagle to pick up the man pages.  

Comment 17 Brian Wheeler 2006-10-25 14:20:15 EDT
This is more of a beagle issue, but I think I should mention it here.  The
/etc/beagle/crawl-documentation doesn't scan man pages at all, so how are you
getting them?  Shouldn't it scan them for Yelp to function better?
Comment 18 Matthew Barnes 2006-10-25 14:22:56 EDT
I don't run beagle.
Comment 19 Brian Wheeler 2006-10-25 14:45:10 EDT
Ah, mystery solved!
Comment 20 petrosyan 2006-11-08 11:15:12 EST
When I search for perl in yelp, it doesn't find the manual page. But "man perl"
works. Why doesn't yelp find perl's man pages when I search for perl?
Comment 21 Matthew Barnes 2006-11-08 12:07:14 EST
Probably because yelp doesn't prioritize the hits, while also limiting the
number displayed.  So the search results are kind of a crapshoot.

The search feature would be much more useful if, for example, hits where "perl"
is found in the document's title were listed first.
Comment 22 Ilya Ryabinkin 2006-11-08 12:48:56 EST
Dear Matthew,
Would you consider a possibility to backport the fixes to the yelp 2.14.3? This
version is in FC5, which is not at EOL yet. Your efforts would be greatly
appreciated by Fedora community (users, namely).
Comment 23 Matthew Barnes 2007-10-02 11:44:39 EDT
Is this problem still present in Fedora 8 Test 2 or later?
Comment 24 Brian Wheeler 2007-10-02 13:57:29 EDT
I was able to search for perl and able to view things which were man pages (The
APR manpage came up).  However when doing any search later it would fail trying
to allocate a pile of memory (4G+).  This was in the latest rawhide.
Comment 25 Matthew Barnes 2007-10-05 11:53:47 EDT
Thanks for responding.  There's plenty of bugs filed about Yelp's inability to
search properly so I'm going to close this particular one since the original
issue seems to be fixed.  Feel free to re-open this if you still have problems
viewing man pages in Yelp.

Note You need to log in before you can comment on or make changes to this bug.