Bug 185528 - /etc/inittab gets deleted after update -> no boot
Summary: /etc/inittab gets deleted after update -> no boot
Status: CLOSED DUPLICATE of bug 197906
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 185731 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-03-15 15:22 UTC by drago01
Modified: 2014-03-17 02:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 19:42:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.log illustrating bad upgrade (22.24 KB, text/plain)
2006-03-15 19:11 UTC, Julian C. Dunn
no flags Details
rpmpkgs file (23.97 KB, text/plain)
2006-03-15 20:33 UTC, Julian C. Dunn
no flags Details
old initscripts rpm (1.17 MB, application/octet-stream)
2006-03-16 19:49 UTC, Bill Nottingham
no flags Details

Description drago01 2006-03-15 15:22:31 UTC
Description of problem:
after updating to initscripts-8.31.1-1  /ect/inittab gots deleted and I 
/etc/inittab.rpmsave got created instead. (no bootable system!)
Version-Release number of selected component (if applicable):
8.31.1-1 

How reproducible:
always

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:

no inittab file found

Expected results:

inittabfile should be found an not dropped by an update (this may even break
fc3/4->fc5 updates)
Additional info:
please mark this as a blocker

Comment 1 Bill Nottingham 2006-03-15 15:42:55 UTC
What were you upgrading from?

Comment 2 Julian C. Dunn 2006-03-15 15:45:18 UTC
I had this problem too, upgrading from initscripts.i386 8.31-1


Comment 3 Jesse Keating 2006-03-15 15:46:03 UTC
We're trying to duplicate this here w/ anaconda upgrades from FC4 to the current
release candidate of FC5.

Comment 4 drago01 2006-03-15 16:06:53 UTC
this info might help:
my rawhide install was installed in textmode so it defaulted to runlevel 3 and I
edited it to be 5 (could it be deleting edited files only?)

Comment 5 Bill Nottingham 2006-03-15 16:16:17 UTC
Is SELinux enabled, and are there any AVC messages?

How did you upgrade - anaconda, yum , or straight RPM?

Was there any messages about saving files as .rpmsave or installing them as .rpmnew?

I can't reproduce this here on a simple 8.31-1 -> 8.31.1-1 upgrade.

Comment 6 drago01 2006-03-15 16:19:59 UTC
(In reply to comment #5)
> Is SELinux enabled, and are there any AVC messages?
> 
enabled no avcs
> How did you upgrade - anaconda, yum , or straight RPM?
> 
pup
> Was there any messages about saving files as .rpmsave or installing them as
.rpmnew?
> 
pup does not show such infos :(
> I can't reproduce this here on a simple 8.31-1 -> 8.31.1-1 upgrade.



Comment 7 Jeremy Katz 2006-03-15 16:38:30 UTC
I can't reproduce either, selinux enabled, using pup, edited /etc/inittab.

Any text spew from pup will end up in your X session log (/tmp/xses.* usually)

Comment 8 drago01 2006-03-15 16:40:38 UTC
(In reply to comment #7)
> I can't reproduce either, selinux enabled, using pup, edited /etc/inittab.
> 

> Any text spew from pup will end up in your X session log (/tmp/xses.* usually)
too late :(
currently installing fc4 on that box to test anaconda update...


Comment 9 Bill Nottingham 2006-03-15 16:54:57 UTC
Can you reproduce it at will by downgrading, moving in your rpmsave file, and
upgrading?

Comment 10 Bill Nottingham 2006-03-15 18:22:02 UTC
Also, did you have *any* third party packages installed?

Comment 11 Julian C. Dunn 2006-03-15 19:11:36 UTC
Created attachment 126163 [details]
yum.log illustrating bad upgrade

Per discussion on the test list, it looks like yum went and uninstalled my
initscripts, which would explain the behaviour... I'll attach the complete
yum.log now.

I have only two "third-party" packages installed: the Cisco VPN client, and
VMWare, but I just reinstalled them and they don't touch /etc/inittab.

Comment 12 Paul Nasrat 2006-03-15 19:22:36 UTC
Thanks, do you have any yum plugins installed/enabled. Can you also attach
/var/log/rpmpkgs*

Comment 13 Paul Nasrat 2006-03-15 19:50:55 UTC
Julian, also if you rollback initscripts to previous version and update does it
recurr?

Comment 14 Julian C. Dunn 2006-03-15 20:32:56 UTC
(In reply to comment #12)
> Thanks, do you have any yum plugins installed/enabled. Can you also attach
> /var/log/rpmpkgs*

The only plugin installed/enabled is "installonlyn" which is what came with
FC4... I'm not too clear on what this does and what its impact might be.

I'll attach the /var/log/rpmpkgs* output now

Comment 15 Julian C. Dunn 2006-03-15 20:33:58 UTC
Created attachment 126167 [details]
rpmpkgs file

Comment 16 Julian C. Dunn 2006-03-15 20:36:00 UTC
(In reply to comment #13)
> Julian, also if you rollback initscripts to previous version and update does it
> recurr?

Paul - can you advise where I could get the old build of initscripts I will try
this and let you know.

Comment 17 drago01 2006-03-16 17:11:27 UTC
(In reply to comment #10)
> Also, did you have *any* third party packages installed?

first: does not happend using anaconda...
2: I had no third party packages installed ; clean rawhide box with some
packages from extras.

Comment 18 Bill Nottingham 2006-03-16 19:49:45 UTC
Created attachment 126244 [details]
old initscripts rpm

Here's the old version of initscripts.

Comment 19 Julian C. Dunn 2006-03-17 14:21:59 UTC
I tried to reproduce the behaviour by installing the old initscripts and doing a
yum update, but the problem did not reoccur.

Comment 20 Bill Nottingham 2006-03-17 16:21:52 UTC
*** Bug 185731 has been marked as a duplicate of this bug. ***

Comment 21 Bill Nottingham 2006-07-10 19:42:56 UTC

*** This bug has been marked as a duplicate of 197906 ***


Note You need to log in before you can comment on or make changes to this bug.