Bug 185778 - pkgconfig file requires fontenc, rpm does not
Summary: pkgconfig file requires fontenc, rpm does not
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libXfont   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
: 185421 196542 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-17 21:39 UTC by Scott Tsai
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 03:17:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Tsai 2006-03-17 21:39:29 UTC
Description of problem:

In /usr/lib64/pkgconfig/xfont.pc, xfont requires fontenc:
"Requires.private: fontenc freetype2"

But none of libXfont-devel's dependencies pulls in libfontenc-devel which has
the required /usr/lib64/pkgconfig/fontenc.pc file.
This causes "pkg-config --list-all" to fail.


Version-Release number of selected component (if applicable):
libXfont-devel-1.0.0-2.2

How reproducible:
always

Steps to Reproduce:
1. Install libXfont-devel but not libfontenc-devel
2. pkg-config --list-all

  
Actual results:
Package fontenc was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontenc.pc'
to the PKG_CONFIG_PATH environment variable
Package 'fontenc', required by 'Xfont', not found

Expected results:
(a list of libraries on the system with .pc files)


Additional info:
A tool to automate pkg-config and rpm dependency checks would be handy.

Comment 1 Mike A. Harris 2006-06-06 03:17:45 UTC
Fixed in 1.1.0-2

Comment 2 Mike A. Harris 2006-06-06 03:18:37 UTC
*** Bug 185421 has been marked as a duplicate of this bug. ***

Comment 3 Mike A. Harris 2006-06-25 19:36:44 UTC
*** Bug 196542 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.