Bug 185820 - nv driver doesn't display mouse cursors
nv driver doesn't display mouse cursors
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-18 15:07 EST by Steven Walter
Modified: 2008-05-06 20:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 20:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg startup log (41.39 KB, text/plain)
2006-03-20 17:42 EST, JF
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12314 None None None Never

  None (edit)
Description Steven Walter 2006-03-18 15:07:31 EST
Description of problem:

Mouse pointer is not visible when running x-windows. The mouse function works
(it tracks properly and the buttons can be pressed) but the pointer/arrow is not
visible. 

This issue occurs when using the FC5 core nv driver on an Nvidia 6100 integrated
graphics motherboard (AsRock K8NF4G-SATA2).

(note: When using a standard PCI external graphics card (NV GeForce 5750 or NV
Geforce 6600GT, the cursor is visible) 

Version-Release number of selected component (if applicable):

Fedora Core 5 test 3
AsRock K8NF4G-SATA2 - Motherboard w/Nvidia 6100 integrated graphics
AMD Sempron 64 3000+

How reproducible:

Reproducible always using NV graphics driver (Autodetected in FC5t3) with a
motherboard using the Nvidia 6100 integrated graphics chip. Run X-Windows 
(Gnome or KDE) and the mouse pointer will not be visible (the mouse will track
and buttons can be pressed however)


Steps to Reproduce:
1. Install FC5t3 on a Motherboard w/Nvidia 6100 integrated graphics (AsRock
K8NF4G-SATA2 for example). nv graphics driver will be autodetected
2. Run X-windows (GNOME or KDE)
3. Mouse cursor is not visible
  
Actual results:

Mouse cursor not visible

Expected results:

Mouse cursor visible

Additional info:

To confirm it was a graphics driver issue. I used the same motherboard with 
an add-in PCI graphics card instead of the integrated 6100 graphics (I used both
a Geforce 5750 and Geforce 6600GT). The mouse cursor was visible with these
external cards.
Comment 1 JF 2006-03-20 17:42:08 EST
Created attachment 126366 [details]
Xorg startup log
Comment 2 JF 2006-03-20 17:44:11 EST
I'm seeing the exact same problem in FC5, except my motherboard is an Asus
A8N-VM which uses the same chipset and same integrated graphics chipset
described above. I've attached my X.org log in case this gives any clues. Also,
I don't know if it's related, but when I boot FC5 (x86_64) on this motherboard I
get a lot of ACPI related errors (I will file a kernel bug for this). I boot
with acpi=off to make things more stable, but even like this the mouse cursor
doesn't show when using the nv xorg driver. The mouse is operational, i.e. I can
see icons highlight etc. when I rollover them, I just can't see the pointer. I
have to use the vesa driver for now to get my mouse to show up properly.
Comment 3 JF 2006-03-20 22:58:11 EST
I found a workaround to make the cursor/pointer work with the nv driver for the
time being... Add the following line to the "Device" section of /etc/X11/xorg.conf

Option      "HWCursor" "off"

Turning HWCursor off at least made the mouse pointer display correctly again,
though the typing cursor/caret looks a little distored (i.e. there is weird gaps
in the vertical flashing bar). Definitely something buggy going on behind the
scenes somewhere.

Comment 4 JF 2006-03-21 14:44:11 EST
Here's a link to an article which talks about the ACPI issues with this board in
more detail and also talks about mouse and sound issues, it also links to a
patch for the ACPI issues:

http://quaggaspace.org/a8nvm/

As for the sound issues, it seems the Alsa project has created a fix in their
latest CVS code, probably will come out with the next release of their stable
tarballs. Hopefully we'll see that new alsa in FC5.

The article suggests turning off legacy USB support in the BIOS to get the mouse
working properly. I tried this and the mouse still doesn't work with HWCursor on
with the nv driver, even with legacy USB support disabled.
Comment 5 Mike A. Harris 2006-03-24 20:03:04 EST

*** This bug has been marked as a duplicate of 182517 ***
Comment 6 Milan Kerslager 2007-09-07 14:43:58 EDT
This is still unresloved (xorg-x11-drv-nv-2.1.3-1.fc8) on Fedora 8 Test 2 with
latest updates installed.

External reference to Freedesktop bugzilla bug #12314 added.
Comment 7 Bug Zapper 2008-04-03 13:08:46 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 8 Bug Zapper 2008-05-06 20:27:12 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.