Bug 185840 - kickstart install traceback
kickstart install traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 186820 187161 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-19 06:57 EST by Florian La Roche
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 22:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2006-03-19 06:57:49 EST
Description of problem:

  File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 1001, in
readKickstart
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 688, in handleCommand
    self.handler.handlers[cmd](self.id, cmdArgs)
  File "/usr/lib/anaconda/kickstart.py", line 572, in doXConfig
    dict["startX"])
  File "/usr/lib/anaconda/installclass.py", line 414, in configureX
    self.setVideoCard(id, driver, videoRam)
  File "/usr/lib/anaconda/installclass.py", line 395, in setVideoCard
    import rhpxl.videocard
ImportError: No module named rhpxl.videocard
install exited abnormally


kickstart contains:
xconfig --monitor "Monitor 1280x1024" --resolution 1280x1024 --depth 16


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-03-20 09:54:49 EST
What version of anaconda is this, and what tree did it come from?  There should
be a /usr/lib/python2.4/site-packages/rhpxl/videocard.py in the second stage
that you're using.
Comment 2 Florian La Roche 2006-03-20 10:37:34 EST
Happens with rawhide tree as well as current FC5 tree from wallace.
This is using "text" and minstg2.img.

regards,

Florian La Roche
Comment 3 Chris Lumens 2006-03-22 10:49:40 EST
Please test with the next anaconda rebuild and let me know if this is working
better.  Looks like we need rhpxl in minstg2 instead of the larger image.
Comment 4 Chris Lumens 2006-03-27 09:37:33 EST
*** Bug 186820 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2006-03-28 16:55:57 EST
*** Bug 187161 has been marked as a duplicate of this bug. ***
Comment 6 Mark 2006-03-28 21:59:43 EST
I'm having the exact same problem. When will the next rebuild of anaconda be
released?
Comment 7 Chris Lumens 2006-03-29 09:38:07 EST
It was rebuilt last night and is in today's Rawhide.
Comment 8 Mark 2006-03-29 10:06:20 EST
I was thinking about this last night on the drive home - the kickstart is
failing before it gets to the RPM intall step, so the problem won't be solved by
updating the RPM. Instead won't I need to replace just the old minstg2.img file
with an fixed version for Core 5? If I attempt to use the one from Rawhide but
it complains about the installer not matching the media. Where can I find an
updated version for Core 5?
Comment 9 Chris Lumens 2006-03-29 10:45:12 EST
You'll need an updates.img with the rhpl library in it.  If you've got a network
connection during install, you can simply add the following to your boot parameters:

        updates=http://people.redhat.com/clumens/185840-i386.img

Otherwise, download the file given by the above URL, dd it to a floppy, and use
the updates boot parameter.  If you don't have a floppy, let me know.
Comment 10 Mark 2006-03-29 11:08:46 EST
Thank you for the help so far, but still no luck.

I've downloaded that image file and added it to my web server and booted from
both PXE and the FC5 cd with the following command:

linux ks=http://mywebserver/fc5.ks http://mywebserver/185840-i386.img 

The installer proceeds to the detecting hardware step and then dies with the 
Import error "No module named rhpxl.videocard"
Comment 11 Mark 2006-03-29 11:11:34 EST
Whoops - I mistyped:

linux ks=http://mywebserver/fc5.ks updates=http://mywebserver/185840-i386.img 
Comment 12 b chang 2006-03-29 13:51:34 EST
(In reply to comment #9)
> You'll need an updates.img with the rhpl library in it.  If you've got a network
> connection during install, you can simply add the following to your boot
parameters:
> 
>         updates=http://people.redhat.com/clumens/185840-i386.img
> 
> Otherwise, download the file given by the above URL, dd it to a floppy, and use
> the updates boot parameter.  If you don't have a floppy, let me know.

is there a separate image for x86_64 FC5 
thanks
Comment 13 Joe Prenger 2006-03-30 16:34:28 EST
no floppy here, I coppied the patch to my custom cd and I'm trying to use the
following update command
(i have modified the isolinux.cfg)

label kick
  kernel vmlinuz
  append initrd=initrd.img ks=cdrom:/ks.cfg updates=cdrom:/185840-i386.img

is this right? or am I doing somthing wrong, I would realy like to get this to work.
Comment 14 Chris Lumens 2006-03-31 10:25:42 EST
Sorry, that was dumb.  I put rhpl in the updates image instead of rhpxl.  Please
try again with the URL of http://people.redhat.com/clumens/185840.img.  I've
removed the -i386 to indicate there's nothing but regular python in this image.

b chang - No, there's not a separate one for x86_64.  Please try with the new
URL and that should work for you.

Joe - if you're creating a new CD image, you should put the updates image in
/Fedora/base on the first CD.  You won't need to provide any special parameters.
Comment 15 Mark 2006-03-31 10:37:33 EST
The kickstart gets farther than before....

The traceback is:
File /usr/bin/anaconda, line 373 in ?
  setup PythonUpdates ()

File /usr/bin/anaconda, line 311 in setup PythonUpdates ()
  for f in os.listdir ("/usr/%s/python%s/site-packages/%s" %(libdir,
 OS Error: [Errno 2] No such file or directory:
'/usr/lib/python2.4/site-packages/rhpxl'
Comment 16 Joe Prenger 2006-04-02 15:51:57 EDT
The kickstart still fails for me, I am using a modified boot iso and from there
a ftp install. I coppied the image to the Fedora/base on my ftp server. How Do i
get the traceback?

Joe
Comment 17 Chris Lumens 2006-04-03 16:43:26 EDT
Has this worked in any previous versions?  I can't see that it has, but maybe
I'm missing something.  We simply do not have the information in text ftp/http
installs to configure X because these installs use minstg2.img, which has none
of the X stuff in it.  Unfortunately, X configuration is very tied in with
running X stuff at the moment.
Comment 18 Mark 2006-04-03 16:48:39 EDT
Yes, I've been able to install workstations with X enabled via the kicstart for
all the previous versions of Fedora Core (I started working with this basic
configuration back in the Redhat 7.3 days). 
Comment 19 Joe Prenger 2006-04-03 21:53:17 EDT
Yes it worked in core 4 just fine, I noticed in 4 that it starts annaconda,
probes for the correct video card and monitor, and then says graphical
installation not avalible switching to text (or something to that effect)

In 5 it simply starts annaconda and the says graphical installation not
availible switching to text.

Hope that helps to shed some light on the situation.

Joe 
Comment 20 Chris Lumens 2006-04-07 11:51:10 EDT
After some additional probing, I've decided I don't think this is fixable as an
update image.  It requires first off the rhpxl library in minstg2.img, plus some
files from the xserver package, plus some additional shared libraries that will
need to be compiled for each platform.  I also had to modify a couple files in
anaconda.  Having done all this, I was able to fix it in Rawhide (I believe) but
not in FC5.  Even after that stuff, there's something else missing in
minstg2.img that's not making it work for FC5.

It's kind of crappy, but please just test this in Rawhide and let me know if
it's working for you.  For FC5, you can either use a graphical install, use a
different install method, or comment out the xconfig line in your kickstart file.
Comment 21 Joe Prenger 2006-04-17 13:10:56 EDT
How Do I test this in Rawhide, Where do I go to download it?

Joe
Comment 22 Chris Lumens 2006-05-23 22:39:04 EDT
Joe - it may be best for you to just wait until FCtest1 at this point, as that
will be much more like a real release instead of trying to use the development tree.

Note You need to log in before you can comment on or make changes to this bug.