Bug 186227 - Yumex dont update or install packages (SELinux = Enforcing)
Summary: Yumex dont update or install packages (SELinux = Enforcing)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 186608 186782 (view as bug list)
Depends On: 186076
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 12:42 UTC by David L.
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 1.0.3-2..0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 06:13:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David L. 2006-03-22 12:42:59 UTC
Description of problem:


Version-Release number of selected component (if applicable):
yumex-0.99.13-1.0.fc5

How reproducible:
seems to be intermittent

Steps to Reproduce:
1. Use yumex to perform update
2. For example, the recent "bind" updates
3. rpm -qa | grep bind indicates some of the packages were installed and old
versions not removed
4. In the recent beagle upgrade, the package was removed, and yum.log says it
was upgraded
  
Actual results:


Expected results:


Additional info:
These problems don't appear with yum, only with yumex, which I find completely
baffling. Therefore not sure what is the most useful info to provide, but will
try to answer questions.

Comment 1 Tim Lauridsen 2006-03-22 13:32:04 UTC
Read this:

http://linux.rasmil.dk/cms/modules/news/article.php?storyid=51

Comment 2 Tim Lauridsen 2006-03-26 09:02:04 UTC
*** Bug 186608 has been marked as a duplicate of this bug. ***

Comment 3 Tim Lauridsen 2006-03-27 06:41:06 UTC
*** Bug 186782 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2006-04-04 07:41:04 UTC
Fixed in the latest fedora SELinux policy (2.2.25-3.fc5).


Comment 5 Dawid Gajownik 2006-10-17 22:54:54 UTC
You should add to the yumex.spec:

Conflicts:     selinux-policy < 2.2.25-3.fc5

I'm reopening this bug because I saw on forum.fedora.pl and Polish usenet groups
more than 5-6 persons who killed their fresh FC5 installations with yumex.

Comment 6 Tim Lauridsen 2006-10-18 05:56:06 UTC
Nice idea i will do that.

Comment 7 Tim Lauridsen 2006-10-18 06:13:57 UTC
I have add the conflicts line to the FC5 spec and requested a new build
yumex-1.0.3-2.0.


Note You need to log in before you can comment on or make changes to this bug.