Bug 186390 - When minimize button clicked focused on e.g. firefox opened window innstead
When minimize button clicked focused on e.g. firefox opened window innstead
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
: 186407 xmms_minimize (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 05:33 EST by maciejK1981
Modified: 2014-06-18 05:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.14.3-1.fc5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 07:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maciejK1981 2006-03-23 05:33:20 EST
Description of problem:
As in summary. When I click to minimize xmms it brings another window to front
instead of minimizing xmms. I have niticed it especially with the firefox
browser. Minimizing do not take any effect.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2006-03-23 13:01:45 EST
*** Bug 186407 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Saou 2006-03-23 13:16:52 EST
I can confirm this problem... but what is happening is that clicking to minimize
xmms makes metacity (the GNOME window manager) crash. Two possibilities :
- The way xmms tries to minimize itself is wrong.
- There is a bug in metacity.
I would tend to suspect a bug in metacity, which might be worth investigating.
Comment 3 Laszlo Dvornik 2006-03-25 07:05:39 EST
Same problem here with bmp, bmpx and audacious. Is it because Metacity doesn't
managed these apps' windows? I mean they use their own window border.
Comment 4 Laszlo Dvornik 2006-03-27 09:05:13 EST
If I rebuild metacity packages without metacity-2.13.144-bling.patch,
metacity-2.13.89.0.2006.02.16-fix-type.patch and
metacity-2.13.89.0.2006.02.16-static-cm.patch, the minimization is OK.
It would be great if the maintainer of the metacity package make a new package
for FC5 updates without experimental bling patches or fix these patches.
It is a very annoying bug. :(
Comment 5 Matthias Saou 2006-03-27 11:27:57 EST
This definitely seems like a metacity bug, but I can't seem to find how to
reassign a bug from en Extras to a Core component... maybe you could file a new
bug against metacity and put a link to it here?
Comment 6 Matthias Saou 2006-03-27 11:31:09 EST
OK, changing the product to Fedora Core worked, so I'll now change the component
to metacity and reassign to the default owner.
Comment 7 Laszlo Dvornik 2006-04-19 06:59:15 EDT
metacity-2.14.3-1.fc5.1 fixed the problem. Please close this bugzilla entry.
Comment 8 Ville Skyttä 2006-12-26 04:34:57 EST
*** Bug 209329 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.