Bug 186551 - LyX-qt crashes when openning a page with a picture inside a float
LyX-qt crashes when openning a page with a picture inside a float
Status: CLOSED DUPLICATE of bug 184508
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 06:14 EST by Persio Barros
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 11:25:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Persio Barros 2006-03-24 06:14:32 EST
Description of problem:
If you try to open a LyX document which have a picture (eps, pdf, fig, etc)
inside float (which is the most common place for a picture), the program crashes
with SIGSEGV while trying to display the page which contains that float.
Interestingly, Lyx doesn't crash if the picture is "in line", i.e. outside a
float environment. It doesn't crashes either if the float is empty or with
documents that have table floats.

Version-Release number of selected component (if applicable):
lyx-1.4.0-4.fc5.i386.rpm
lyx-qt-1.4.0-4.fc5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Open a document with a picture inside a float. For example, go to
help->User's Guide.

2. Navigate to the page with the picture float. In the example given, go to
section 4.3 Figures and Imported Graphics.

3. CRASH!
  
Actual results:
SIGSEGV

Expected results:
The picture should be displayed

Additional info:
This may be a severer version of bug 186319
Comment 1 Rex Dieter 2006-03-24 07:28:45 EST
Looks like a dup of bug #184508
Comment 2 Persio Barros 2006-03-24 11:25:26 EST
Yes, indeed.
Sorry, I didn't see that bug submition. It was submited for the "devel" version,
which I didn't try.
By the way, why was LyX-1.4.0-4 deployed in the Fedora-extras-5 final with this
severe and already known bug?


*** This bug has been marked as a duplicate of 184508 ***
Comment 3 Rex Dieter 2006-03-24 12:33:35 EST
Didn't know until recently how widespread the problem really was.  Before now,
we'd only had 1 report from 1 user.

Note You need to log in before you can comment on or make changes to this bug.