Bug 184508 - lyx: crashes with "graphics preview"
lyx: crashes with "graphics preview"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 186551 188201 (view as bug list)
Depends On:
Blocks: 184475
  Show dependency treegraph
 
Reported: 2006-03-09 07:35 EST by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: lyx-1.4.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-13 09:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace (4.38 KB, text/plain)
2006-03-09 07:35 EST, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2006-03-09 07:35:40 EST
Description of problem:   
   
crashes when scrolling   
Version-Release number of selected component (if applicable):   
   
   
How reproducible:   
evertime   
   
Steps to Reproduce:   
1. help/user guide  
2. scroll  
3.   
     
Actual results:   
   
   
Expected results:   
   
   
Additional info:
Comment 1 Neal Becker 2006-03-09 07:35:41 EST
Created attachment 125873 [details]
trace
Comment 2 Rex Dieter 2006-03-09 09:40:40 EST
What version-release of lyx are you using?
rpm -q lyx

Unfortunately, I don't have a fc5 box, so I cannot reproduce.  lyx-1.4.0-3 works
fine for me on my rhel4 boxes.

I assume you're using the qt frontend?  If so, try installing lyx-xforms.  Does
the problem occur there too?

Comment 3 Neal Becker 2006-03-09 09:43:56 EST
lyx-1.4.0-3.fc5 
Yes, using qt frontend. 
 
Comment 4 Rex Dieter 2006-03-09 11:13:55 EST
Turns out the existing builds (lyx <= 1.4.0-3) were still using -fexceptions in
the compiler flags, so we'll rebuild with that fixed to see if it helps.
Comment 5 Alex Lancaster 2006-03-09 18:15:57 EST
Hmm, can't duplicate this here on my Rawhide box with lyx-1.4.0-3.fc5.  I tried
scrolling with keys (PageUp, PageDown) and with the mouse after opening the User
Guide, but I get no crash.   I have rawhide-20060308.
Comment 6 Alex Lancaster 2006-03-09 18:27:51 EST
OK, now I can duplicate it after upgrading to rawhide-20060309.  However it
requires a very quick up and down scroll for it to happen and even then, not
every time.  The backtrace looks similar.
Comment 7 Neal Becker 2006-03-09 19:44:47 EST
Depends on content.  Crashes every time for me, both when viewing 'help user's 
guide' and, unfortunately, the _paper I'm trying to write_.  Really not 
usable. 
Comment 8 Rex Dieter 2006-03-10 08:06:11 EST
Please try to reproduce with lyx-1.4.0-4 (should be released yesterday or today).
Comment 9 Neal Becker 2006-03-10 08:23:02 EST
Still waiting for lyx-1.4.0-4. 
 
In the meantime, note 1.4.0-3 crashes in same manner for lyx-xforms. 
Comment 10 Neal Becker 2006-03-10 13:21:33 EST
Nope, same crash with lyx-1.4.0-4 
 
Rex, I can provide you with my paper to test with, but I don't want to  
post it publically. 
Comment 11 Rex Dieter 2006-03-10 13:24:52 EST
May have to wait for fc5 final... I have no fc5 boxes (and won't until it's
released).

Feel free to send test-cases to me privately to rdieter@math.unl.edu.
Comment 12 Mark van Rossum 2006-03-11 06:55:35 EST
Me too:
I also see this on my box w. lyx 1.4.0-4
For me it does not depend on the speed, but it crashes in the userguide in 
section 4, where the figure is.

(Ps. dvi export of the userguide fails as well).
Comment 13 Rex Dieter 2006-03-23 08:42:47 EST
See also "lyx crash following fc4->fc5" upstream report:
http://bugzilla.lyx.org/show_bug.cgi?id=2414
Comment 14 Chris Shucksmith 2006-03-23 11:08:50 EST
For me, a suitable workaround is to use the Lyx FC4 packages in FC5
# yum remove lyx
# wget ftp://fr.rpmfind.net/linux/fedora/extras/4/i386/lyx-1.4.0-4.fc4.i386.rpm
# wget ftp://fr.rpmfind.net/linux/fedora/extras/4/i386/lyx-qt-1.4.0-4.fc4.i386.rpm
# rpm -iv lyx-qt-1.4.0-4.fc4.i386.rpm lyx-1.4.0-4.fc4.i386.rpm
Comment 15 Rex Dieter 2006-03-23 11:11:12 EST
Interesting... that smacks of a compiler bug (or at least an incompatibility).
Comment 16 Chris Shucksmith 2006-03-23 11:59:22 EST
I'm out of my depth here. 
Reading around i see someone with more experiance used a diff of object dumps on
 two binaries to diagnose. Perhaps I can try that. see
http://kernelslacker.livejournal.com/36756.html
I believe something similar was used after the release of FC4 with an xorg
problem switching virtual terminals on matrox cards (maybe?). problem with
ambiguity in the original code. Might be a way forward for the two lyx-qt binaries?

I know FC4 was build on 4.0.x and the FC5 release notes:
The GCC 4.1 compiler is included, and the entire set of Fedora packages is built
with this technology. This provides security and performance enhancements
throughout the system.

Does the build system for FC5 Extras also use 4.1?
Comment 17 Rex Dieter 2006-03-23 12:00:44 EST
Yes, FC5 uses gcc-4.1 throughout, including for Extras
Comment 18 Persio Barros 2006-03-24 11:25:38 EST
*** Bug 186551 has been marked as a duplicate of this bug. ***
Comment 19 Rex Dieter 2006-03-28 10:26:54 EST
See also upstream report:
"Crash in 1.4.0 on graphics preview"
http://bugzilla.lyx.org/show_bug.cgi?id=2376

It appears that one workaround is to disable/turn-off graphics preview.
Comment 20 Rex Dieter 2006-03-29 09:15:55 EST
If any of you are willing, try out this test build:
http://apt.kde-redhat.org/apt/kde-redhat/mock/fedora-5-i386-core/lyx/

Let me know if it helps.
Comment 21 Rex Dieter 2006-03-29 10:05:37 EST
Nevermind about the test binary... already got a couple reports that it crashes too.
Comment 22 Rex Dieter 2006-04-06 21:40:29 EDT
*** Bug 188201 has been marked as a duplicate of this bug. ***
Comment 23 Simon Goodall 2006-04-07 04:29:52 EDT
I've been having the same problem. Lyx will crash even if the image does not
exist. Disabling graphics works for me.

I managed to rebuild it with the 3.2 compiler and that works with graphics on.
Comment 24 Rex Dieter 2006-04-07 05:04:14 EDT
How did you build with the 3.2 compiler?  I already tried that, but it fails to
link against qt (because qt was built with gcc-4.1).
Comment 25 Simon Goodall 2006-04-07 05:37:36 EDT
I built from souce using the following cmd to run configure. I'm not sure if you
actually need all the extra bits except the CXX= and CC= parts, but I haven't
tried compiling without them.

CXX=gcc32  CC=gcc32 CFLAGS="-ggdb -O0" CPPFLAGS="-ggdb -O0" CXXFLAGS="-ggdb -O0"
./configure  --with-frontend=qt QTDIR=/usr/lib/qt-3.3/ --enable-debug 
--enable-optimization=no  --with-included-boost=yes

This fails to link due to missing stdc++, so I cut 'n' paste the linker command
and added -lstdc++ and it built.
I got a warning about linking to qt, but it still seems to run.

(btw I made sure all gcc3 based rpms were installed, so the compat rpm and the
compiler rpm at least)
Comment 26 Neal Becker 2006-04-07 09:04:22 EDT
I just built lyx-1.5.0svn with boost-1.34 and it does NOT crash. 
Comment 27 Rex Dieter 2006-04-12 10:33:07 EDT
lyx-1.4.1 has been pushed to Fedora Extras.  Please upgrade, and confirm/deny
the continued existence of crash(es).
Comment 28 Rex Dieter 2006-04-13 09:33:44 EDT
I've received several confirmations (as well as testing it myself) that
lyx-1.4.1 no longer crashes.  Please report back if you find otherwise.
Comment 29 Neal Becker 2006-04-13 09:37:47 EDT
The old crash (preview) seems to be fixed, but I still got a crash that  
appears to be different. 
 
1.5.0svn + boost-1.34 seems a lot more stable. 
Comment 30 Rex Dieter 2006-04-13 09:54:40 EDT
Neal, please file a separate report for your other issue(s), if you haven't
already.  1.5.0 release is still awhile off... (-:  (and boost-1.34 isn't
released either?)

Note You need to log in before you can comment on or make changes to this bug.