Bug 18673 - Procinfo miscalculates uptime
Procinfo miscalculates uptime
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procinfo (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 20017 20338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 01:11 EDT by Jamie Manley
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 07:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Manley 2000-10-09 01:11:31 EDT
Both machines of mine that have been upgraded to RH7.0 show the wrong value
for uptime and idle time when queried via procinfo.  Same kernel (which
reported correct values under 6.2) is running.  This is from my NAT proxy
machine:

Bootup: Sat Sep 30 02:34:55 2000    Load average: 0.00 0.00 0.00 1/23 21453

user  :       0:19:53.88   0.2%  page in :  1060184  disk 1:    49267r   28443w
nice  :       0:00:00.00   0.0%  page out:   125512
system:       0:03:46.75   0.0%  swap in :     2358  disk 3:   265554r   16347w
idle  :   3d 19:49:08.00  99.8%  swap out:     1239
uptime:   3d 20:12:48.62         context :  1566712

AT motherboard/case, no APM configured in the kernel, apmd installed but
not running, all power management off in the BIOS.
Comment 1 Jamie Manley 2000-10-11 05:23:42 EDT
Forgot to mention that both cases, including the one quoted above are with
unpatched 2.2.17 kernels.
Comment 2 Bernhard Rosenkraenzer 2000-10-16 07:48:06 EDT
Verified; fixing.
Comment 3 Bernhard Rosenkraenzer 2000-10-16 08:08:06 EDT
It's caused by a change in the compiler.
Looks like procinfo code has always relied on a compiler bug. ;)
Fixed in 17-9.
Comment 4 Bernhard Rosenkraenzer 2000-10-30 05:17:18 EST
*** Bug 20017 has been marked as a duplicate of this bug. ***
Comment 5 Ed McKenzie 2000-11-04 14:16:16 EST
*** Bug 20338 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.