Bug 186861 - Hotkey binding configuration per language/locale
Hotkey binding configuration per language/locale
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scim (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: FutureFeature, i18n, Reopened
Depends On:
Blocks: SCIM 182539
  Show dependency treegraph
 
Reported: 2006-03-26 23:14 EST by Qingyu Wang
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 22:40:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"hotkey per locale" patch (2.95 KB, patch)
2006-03-26 23:18 EST, Qingyu Wang
no flags Details | Diff
the new version of the "hotkeys per locale" patch (2.95 KB, text/x-patch)
2006-06-07 05:18 EDT, Qingyu Wang
no flags Details

  None (edit)
Description Qingyu Wang 2006-03-26 23:14:34 EST
Business Justification:
The hotkey of SCIM works great for Chinese users, but it is problematic for the
majority of users of other languages. Such as Japanese or Korean, who use
different hotkeys with what Chinese use(ctrl+space). So we need to write a patch
to resovle this problem, providing hotkeys for per locale/language.
Comment 1 Qingyu Wang 2006-03-26 23:16:16 EST
I implemented the "Hotkey per language(actually is "Hotkey per locale")"
feature. The attachment above is my patch.
Comment 2 Qingyu Wang 2006-03-26 23:18:45 EST
Created attachment 126783 [details]
"hotkey per locale" patch
Comment 3 Jens Petersen 2006-04-11 00:48:09 EDT
I think the suggestion that krishna made:

  http://sourceforge.net/mailarchive/forum.php?thread_id=10090487&forum_id=43684

to support locale specific config files is a good one.
It will also make it easier to support other lang specific
hotkeys, eg next and previous factory for example.
Comment 4 Qingyu Wang 2006-06-07 05:18:34 EDT
Created attachment 130662 [details]
the new version of the "hotkeys per locale" patch
Comment 5 Jens Petersen 2006-06-16 08:14:17 EDT
I finally got round to testing it and it doesn't seem to work for me I'm afraid.
Comment 6 Jens Petersen 2006-06-16 08:15:33 EDT
Ctrl+space is still default for me in both Japanese and Korean.
Comment 7 Jens Petersen 2006-06-19 04:17:29 EDT
(In reply to comment #6)
> Ctrl+space is still default for me in both Japanese and Korean.

Okay, sorry I better take that back, it does work for me with a fresh
rawhide install.
Comment 8 A S Alam 2006-07-04 06:36:07 EDT
behaviour is following
-----------
ja_JP -> Alt+`
ko_KR -> Shift+SPACE
zh_CN/zh_TW->Ctrl+SPACE
-----------

Test Under following Envirnment:
-----------
RAWHIDE (FC6)
scim-1.4.4-21
-----------
Comment 9 Jay Turner 2006-09-22 00:32:04 EDT
Latest RHEL5 trees include scim-1.4.4-34.fc6.
Comment 10 Jens Petersen 2006-12-10 21:39:29 EST
The default empty Next/Previous Factory bindings for non-Chinese locale
does not seem to work.
Comment 12 Jens Petersen 2006-12-11 22:40:11 EST
Okay, let me move this back to CLOSED and open a new bug for
next/previous factory issue.
Comment 13 Jens Petersen 2006-12-11 23:46:40 EST
I opened bug 219247 against FC for comment 10.
Comment 14 Jens Petersen 2007-06-18 21:15:50 EDT
Removing rhel‑5.1.0 flag since this work was basically done in 5.0
but bug 244761 is open for the above issue.

Note You need to log in before you can comment on or make changes to this bug.