Bug 187593 - Unlisted dependancy for pycrust?
Unlisted dependancy for pycrust?
Status: CLOSED DUPLICATE of bug 185777
Product: Fedora
Classification: Fedora
Component: wxPythonGTK2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 09:28 EST by Brad Smith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-01 11:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Smith 2006-04-01 09:28:47 EST
I used Yum to install wxPythonGTK2 v2.4.2.4-7 for i386. It installed without
incident but attempting to run pycrust, which is included with this package
produces the following:

[brad@satsuki ~]$ pycrust
Traceback (most recent call last):
  File "/usr/bin/pycrust", line 3, in ?
    from wx.py.PyCrust import main
  File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
    from wxPython import wx
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context

I'm assuming that pycrust depends on something that the rpm doesn't require, but
I'm not sure what. pango-1.12.0-1 and pango-devel-1.12.0-1 are both installed.
The actual failure is in a library provided by compat-wxGTK2-2.4.2-17.fc5, so
maybe this bug should be filed there. This problem also applies to pyshell,
pyalacarte, etc.
Comment 1 Matthew Miller 2006-04-01 11:07:35 EST
thanks for the report. wxPython is currently just flat-out broken on FC5. This
is basically a dup of bug #185777, but also see bug #163440 for details of
progress towards getting it all straightened out.

*** This bug has been marked as a duplicate of 185777 ***
Comment 2 Brad Smith 2006-05-05 14:37:34 EDT
This problem still exists with 

[brad@satsuki ~]$ rpm -qa | grep -i wx
compat-wxGTK2-gl-2.4.2-17.fc5
compat-wxGTK-common-2.4.2-17.fc5
wxPythonGTK2-2.4.2.4-7
compat-wxGTK2-2.4.2-17.fc5
wxGTK-2.6.3-2.6.3.2.1.fc5

Note You need to log in before you can comment on or make changes to this bug.