Bug 18780 - up2date/rhn proxy
Summary: up2date/rhn proxy
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 22365 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-10 07:52 UTC by Need Real Name
Modified: 2015-01-07 23:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 19:55:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to rhn_register-1.3.2 to support proxy authentication (5.12 KB, patch)
2001-04-22 00:41 UTC, Need Real Name
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Need Real Name 2000-10-10 07:52:02 UTC
Hope I understood everything.

Up2date tells me, that I'm not registered.
Trying to register fails, since rhn_register won't use a proxy.
Up2date could you a proxy.

Is it right, that you broke up2date (in using rhn) for users behind proxies
?

It seems, that I have a valid RHn Account, but I can't use it without using
rhn_register.

Thanks.

Comment 1 Preston Brown 2000-10-10 15:25:00 UTC
*** Bug 18817 has been marked as a duplicate of this bug. ***

Comment 2 Preston Brown 2000-10-10 15:55:31 UTC
Can you please try specifying your serverURL in /etc/sysconfig/rhn/up2date as:

 http://your.proxy.here/https://www.rhns.redhat.com/XMLRPC

 And let me know if that works?

Comment 3 Preston Brown 2000-10-10 15:55:55 UTC
*** Bug 18817 has been marked as a duplicate of this bug. ***

Comment 4 Need Real Name 2000-10-10 17:35:23 UTC
No it does not... Squid does not seem to handle the following request:

971196098.518      5 10.0.217.18 NONE/400 1123 POST
/https://www.rhns.redhat.com/XMLRPC - NONE/- -

As a quick try I added

  if string.find(self.__handler,"/http") == 0:
           self.__handler = string.replace(self.__handler,"/http","http")

to xmlrpclib (line ?) just to discover that all does not work with ssl (POST is
wrong. Should be CONNECT etc.) . If you use both with http it works. But it is
really not nice. 
It seems that using ssl and proxy  really needs a bit of work.



Comment 5 Cristian Gafton 2001-02-20 01:34:38 UTC
Assigned QA to jturner

Comment 6 Jay Turner 2001-03-01 13:37:15 UTC
Proxy support for both up2date and rhn_register is currently in the CVS versions
and therefore will be rolled out in the next cut of the software made public.

Comment 7 Preston Brown 2001-03-28 19:54:52 UTC
*** Bug 22365 has been marked as a duplicate of this bug. ***

Comment 8 Preston Brown 2001-04-12 20:53:10 UTC
fixed in errata release, due out today.

Comment 9 Need Real Name 2001-04-18 16:32:58 UTC
is this actually fixed? I've set up both the proxy name and the authentication 
details and a netstat -a shows it still SSL'ing to 216.148.218.160 for the 
welcome message.

Comment 10 Jay Turner 2001-04-18 16:43:19 UTC
This is working for me.  I ran 'rhn_register --config' and set attribute 2 to
'http:<proxy name>:<proxy port>' and set attribute 1 to 'yes' and that was all
that it took.

Comment 11 Need Real Name 2001-04-21 19:15:14 UTC
I'm now getting 'unable to set up CONNECTION tunnel'. I didn't see any options 
as there are on up2date for setting my username and password for the 
authenticated proxy.

I would suggest altering the comment for the rhn_register config. attribute 2 
that says u must but the 'http://' in.


Comment 12 Need Real Name 2001-04-22 00:41:23 UTC
Created attachment 16004 [details]
patch to rhn_register-1.3.2 to support proxy authentication

Comment 13 Need Real Name 2001-04-22 00:43:14 UTC
The above patch allows rhn_register to work through a proxy with 
authentication, I've only tested it with authentication on.

Comment 14 Preston Brown 2001-04-27 18:04:51 UTC
this patch will be included in a future errata release of rhn_register.

Comment 15 Need Real Name 2001-04-29 05:44:56 UTC
we used to fix our bugs for free (hey bill..... is that you out there ??? do 
you own redhat too???) now you foist off beta garbage as a finished 
product.... re-invent a lesser wheel.... hey you make bill gates almost nice !

talking about rh 7.1..... 6.2 was more stable ! can't you say "whoops" and say 
"click here to update " ????


Note You need to log in before you can comment on or make changes to this bug.