Bug 188391 - 2.6.16-1.2069_FC4 kernel breaks suspend/resume on IBM T-21
2.6.16-1.2069_FC4 kernel breaks suspend/resume on IBM T-21
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 18:25 EDT by Mitch Smith
Modified: 2008-05-06 11:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:46:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg diff between resuming and non-resuming kernels (13.57 KB, text/plain)
2006-04-27 19:37 EDT, Michal Jaegermann
no flags Details
dmesg from boot of "resuming" 2.6.15-1.1833_FC4 kernel (14.43 KB, text/plain)
2006-04-27 19:39 EDT, Michal Jaegermann
no flags Details
dmesg from boot of "non-resuming" 2.6.16-1.2096_FC kernel (14.45 KB, text/plain)
2006-04-27 19:41 EDT, Michal Jaegermann
no flags Details
dmesg from boot 2.6.16-1.2096_FC using 'noapic' - resumes (15.04 KB, text/plain)
2006-04-27 19:42 EDT, Michal Jaegermann
no flags Details
messages from suspend/restore sequence for 2.6.16-1.2096_FC4 using 'noapic' (6.46 KB, text/plain)
2006-04-27 19:44 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Mitch Smith 2006-04-08 18:25:47 EDT
Description of problem: upgrade to kernel-2.6.16-1.2069_FC4 breaks ability of
laptop to resume after suspend.

How reproducible: happens every suspend/resume cycle and requires reboot to fix.
However, if I revert to kernel-2.6.15-1.1833_FC4 the suspend/resume works normally. 

Steps to Reproduce:
1. laptop involved is IBM T-21. Boot with 16-1.2069 kernel.
2. Use suspend script (echo 3 > /proc/acpi/sleep)
3. When Fn key pressed or lid opened, unit won't resume.
4. Depress power button until unit shuts off and reboot.
Comment 1 Michal Jaegermann 2006-04-27 19:35:49 EDT
I run into exactly the same problem with Acer Travelmate 230.  On an attempt
to resume something scribbles a bit over a video buffer (yellow letters
"inu" show up at topmost row of a screen and a message is printed

   ACPI: PCI Interrupt 0000:00:1f.1[A]: no GSI

After that there is a power button time.  The same happens with
2.6.16-1.2096_FC4.

Further investigations reveal that I need to boot with 'noapic' option to
be able to resume again.  Trying 'nolapic' goes nowhere as this reaches
only 'hda: max request size: 128KiB' and quietly stops there. You can
get 'hda: lost interrupt' if you wait long enough.  Suggested in
some dmesg output 'pci=assign-busses' in my case affects only how some
interrupts are assigned but does not help with ability to resume at all.

Attached are
  - diff between dmesg from boot between resuming (2.6.15-1.1833_FC4)
    and non-resuming ("unadorned" 2.6.16-1.2096_FC4)
  - dmesg for 2.6.15-1.1833_FC4
  - dmesg for 2.6.16-1.2096_FC4
  - dmesg for 2.6.16-1.2096_FC4 where 'noapic' is used and I can resume again
  - a fragment of dmesg to show how suspend/resume sequence looks with
    2.6.16-1.2096_FC4 and 'noapic'
Comment 2 Michal Jaegermann 2006-04-27 19:37:41 EDT
Created attachment 128328 [details]
dmesg diff between resuming and non-resuming kernels
Comment 3 Michal Jaegermann 2006-04-27 19:39:26 EDT
Created attachment 128329 [details]
dmesg from boot of "resuming" 2.6.15-1.1833_FC4 kernel
Comment 4 Michal Jaegermann 2006-04-27 19:41:00 EDT
Created attachment 128330 [details]
dmesg from boot of "non-resuming" 2.6.16-1.2096_FC kernel
Comment 5 Michal Jaegermann 2006-04-27 19:42:26 EDT
Created attachment 128331 [details]
dmesg from boot 2.6.16-1.2096_FC using 'noapic' - resumes
Comment 6 Michal Jaegermann 2006-04-27 19:44:20 EDT
Created attachment 128332 [details]
messages from suspend/restore sequence for 2.6.16-1.2096_FC4 using 'noapic'
Comment 7 Dave Jones 2006-09-16 22:28:57 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 8 Michal Jaegermann 2006-09-17 00:51:56 EDT
> Please retest with Fedora Core 5.

I cannot tell anything about a situation on IBM T-21 from the original
report and I am not in a position to retest with Fedora Core 5.
But with 2.6.17-1.2142_FC4 a situation described in comment #1
and following did not change.  When booting with 'noapic' then
Acer Travelmate 230 resumes after a suspend; otherwise it is a forced
reboot time.

In not so distant future will check with FC6.
Comment 9 Dave Jones 2006-10-16 17:36:28 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 10 Nigel Cunningham 2007-12-10 17:12:34 EST
Hi.

Have you been able to retest this with a more recent Fedora release (ideally
Fedora 7 or 8)?
Comment 11 Michal Jaegermann 2007-12-10 19:26:01 EST
I have no idea about IBM T-21 from the original report.  OTOH on
a laptop mentioned in comment #1 there was some moments in FC6 when
"suspend" did work but that did not last.  Later FC6 kernels broke
that again.  "Hibernate" though, i.e. to disk, worked quite reliably
all the time and was reasonably fast.

A recent upgrade to Fedora 8 promptly broke all that as anaconda
removed 'acpi_sleep=s3_bios' from a boot line.  Without that
parameter the laptop refuses both "suspend" and "hibernate".

Restoring 'acpi_sleep=s3_bios' and rebooting with 2.6.23.8-63.fc8
improves the situation a bit. 'pm-suspend' causes the laptop to
suspend.  Waking it up is another story.  From a console a screen
remains blank and there is no network access.  The whole thing
is not entirely dead, though, as a short push on a power switch
causes an orderly shutdown.  Trying that from a graphic session
produces on an attempted wake-up what looks like a series of
crashes of X server in a loop with a screen blank all the time but
with a varying depth of gray.  Possibly some vbetool hacks may
bring some sense into this but I did not have time to experiment
with such workarounds yet.

"Hibernate" is better.  Both console and graphics sessions are 
restored on wake-up although with FC6 that process was markedly faster.
In particular X server now takes its sweet time and a lots of blinking
before some picture eventually appears.
Comment 12 Bug Zapper 2008-04-03 22:35:45 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 13 Michal Jaegermann 2008-04-03 23:01:35 EDT
See bug 437886 about what is required for some laptops.
If something like this applies to T-21 I have no idea.
Comment 14 Bug Zapper 2008-05-06 11:46:19 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.